aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:59 +0000
commit5c8819fc34f1811e9d3c4e0f73877668eb78be7d (patch)
tree6225fc11536be22c4fec2a81d1ba55ada9b4fa1e
parent3eeb7b7a5b855fce94e7e9c73a05a64d45739f21 (diff)
downloadmaster-187ad058-5c8819fc34f1811e9d3c4e0f73877668eb78be7d.tar.gz
master-187ad058-5c8819fc34f1811e9d3c4e0f73877668eb78be7d.tar.bz2
master-187ad058-5c8819fc34f1811e9d3c4e0f73877668eb78be7d.zip
ar71xx: specify console kernel parameter for the Compex boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29660 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 78bf7e39c7..4e143ddc0e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -258,10 +258,11 @@ endef
define Image/Build/MyLoader
- -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(3) \
- -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR)/vmlinux.bin.lzma \
+ $(call PatchKernelLzma,$(2),$(3))
+ -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \
+ -p0x030000:0xe0000:al:0x80060000:kernel:$(KDIR)/vmlinux-$(2).bin.lzma \
-p0x110000:0:::rootfs:$(KDIR)/root.$(1) \
- $(call imgname,$(1),$(2))-$(4)-factory.img
+ $(call imgname,$(1),$(2))-$(5)-factory.img
endef
ubntxm_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware)
@@ -637,11 +638,12 @@ define Image/Build/Profile/PB92
$(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),,917504,2818048,KR)
endef
+wp543_cmdline=console=ttyS0,115200
define Image/Build/Profile/WP543
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x200000,2M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x400000,4M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x800000,8M)
- $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,0x1000000,16M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x200000,2M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x400000,4M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x800000,8M)
+ $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x1000000,16M)
endef
dir600a1_cmdline=board=DIR-600-A1 console=ttyS0,115200