aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-23 02:08:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-23 02:08:34 +0000
commit4b4bb6062ec65b32f27ba7ca85a43f25464a8b76 (patch)
tree2dbaaca8613a0fe3535785e8458d503c952a8f5f
parentf807a418e76682a3b5f8c2c932486f8ca367ea3f (diff)
downloadmaster-187ad058-4b4bb6062ec65b32f27ba7ca85a43f25464a8b76.tar.gz
master-187ad058-4b4bb6062ec65b32f27ba7ca85a43f25464a8b76.tar.bz2
master-187ad058-4b4bb6062ec65b32f27ba7ca85a43f25464a8b76.zip
add profile specific base-files packages - does not work with the imagebuilder yet, but will be fixed later
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9870 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1ef64ac9c1..6e85bb98d9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -18,6 +18,9 @@ include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
TARGET:=-$(BOARD)
+ ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
+ TARGET:=$(TARGET)-$(PROFILE)
+ endif
LIBGCC_VERSION:=$(GCC_VERSION)
else
UCLIBC_VERSION:=<UCLIBC_VERSION>
@@ -129,10 +132,16 @@ define Package/base-files$(TARGET)/install
if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
fi
+ if [ -d $(PLATFORM_DIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_DIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi
$(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
$(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
fi \
+ if [ -d $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi \
)
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf