aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-02 00:33:49 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-02 00:33:49 +0000
commit47a347af72fc7f584ed193096a77ffe4710996fe (patch)
tree1b8742fa3d58433951f69ae7222f351aa409b5be
parente92e06ddbbdd5dc9ed0e0b5114854c18827b0524 (diff)
downloadmaster-187ad058-47a347af72fc7f584ed193096a77ffe4710996fe.tar.gz
master-187ad058-47a347af72fc7f584ed193096a77ffe4710996fe.tar.bz2
master-187ad058-47a347af72fc7f584ed193096a77ffe4710996fe.zip
imx6: add default profile
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38282 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/imx6/Makefile3
-rw-r--r--target/linux/imx6/profiles/100-Generic.mk19
2 files changed, 20 insertions, 2 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index b9b2062ef3..3af424e64c 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:="zImage dtbs"
-DEFAULT_PACKAGES += \
- kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
+DEFAULT_PACKAGES +=
$(eval $(call BuildTarget))
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-Generic.mk
new file mode 100644
index 0000000000..91ca3696ad
--- /dev/null
+++ b/target/linux/imx6/profiles/100-Generic.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic (default)
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))