aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-22 09:39:41 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-22 09:39:41 +0000
commit3f7b7dc29e3a0144ead149af22edcce8960816c9 (patch)
treeb158d1ac046a4534d849744c82980da6bd52ddbc
parentc01716afd0fca332c8bd2d14cbeacaa38e635dca (diff)
downloadmaster-187ad058-3f7b7dc29e3a0144ead149af22edcce8960816c9.tar.gz
master-187ad058-3f7b7dc29e3a0144ead149af22edcce8960816c9.tar.bz2
master-187ad058-3f7b7dc29e3a0144ead149af22edcce8960816c9.zip
allow configuration of the target directory for binaries
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38890 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in4
-rw-r--r--rules.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 4f7667aa1f..bf1e139f2e 100644
--- a/Config.in
+++ b/Config.in
@@ -421,6 +421,10 @@ menuconfig DEVEL
bool "Show broken platforms / packages" if DEVEL
default n
+ config BINARY_FOLDER
+ string "Binary folder" if DEVEL
+ default ""
+
config DOWNLOAD_FOLDER
string "Download folder" if DEVEL
default ""
diff --git a/rules.mk b/rules.mk
index a3efb7db4f..80e07d11a2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -73,7 +73,7 @@ ifdef CONFIG_MIPS64_ABI
endif
DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
-BIN_DIR:=$(TOPDIR)/bin/$(BOARD)
+BIN_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin/$(BOARD))
INCLUDE_DIR:=$(TOPDIR)/include
SCRIPT_DIR:=$(TOPDIR)/scripts
BUILD_DIR_BASE:=$(TOPDIR)/build_dir