aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-04-08 05:55:28 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-04-08 05:55:28 +0000
commit3a2f07960fc5ca5f08e665fae7925485d1fc8ed5 (patch)
tree8a27b6761a9708e9c44858e43f4a5fcd34701781
parenta07a3cb28f66c4589afb9bc5a506650271195964 (diff)
downloadmaster-187ad058-3a2f07960fc5ca5f08e665fae7925485d1fc8ed5.tar.gz
master-187ad058-3a2f07960fc5ca5f08e665fae7925485d1fc8ed5.tar.bz2
master-187ad058-3a2f07960fc5ca5f08e665fae7925485d1fc8ed5.zip
mac80211: make b43 N-PHY default for brcm47xx legacy subtarget
Subtarget legacy is supposed to support all ssb SoC except for BCM4705. There are few BCM4703 devices with 802.11n supprt (WRT160N v1.0, v1.1). Few BCM4704 devices with 802.11n: ASUS WL-500W, Linksys WRT150N v1.0 & v1.1, Linksys WRT300N v1.0, Netgear WNDR3300 v1, WNR834B v1 & v2. It seems we have to enable N-PHY for legacy as well to support above. Unfortunately it increases root.squashfs size by 48 460 B. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45309 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/mac80211/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 11c8bcfa1a..2a40bb1933 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1235,9 +1235,9 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_SQUASH_PHYTYPES
string "PHY types to include"
depends on B43_FW_SQUASH
- default "G,LP" if TARGET_brcm47xx_legacy
+ default "G,N,LP" if TARGET_brcm47xx_legacy
default "N,HT" if TARGET_brcm47xx_mips74k
- default "G,LP,N,HT"
+ default "G,N,LP,HT"
help
This is a comma seperated list of PHY types:
A => A-PHY
@@ -1307,7 +1307,6 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_N
bool "Enable support for N-PHYs"
- default n if TARGET_brcm47xx_legacy
default y
help
Enable support for N-PHY. This includes support for the following devices: