aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:05 +0000
commit39492aef2b08cf92cc72799c72071613eadd2ac2 (patch)
tree3c695a2719872ab3ebd00a9e63524ccad9b4ddad
parentef7cecd1412eb3e2f9fe35f33b65740f79a0e577 (diff)
downloadmaster-187ad058-39492aef2b08cf92cc72799c72071613eadd2ac2.tar.gz
master-187ad058-39492aef2b08cf92cc72799c72071613eadd2ac2.tar.bz2
master-187ad058-39492aef2b08cf92cc72799c72071613eadd2ac2.zip
tools: add expat library (to be used by gdb)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46297 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/Makefile2
-rw-r--r--tools/expat/Makefile25
2 files changed, 26 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 2f516d2383..8b5dd6c520 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -23,7 +23,7 @@ ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSM
BUILD_B43_TOOLS = y
endif
-tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf
+tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf expat
tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
new file mode 100644
index 0000000000..dfd5f286cd
--- /dev/null
+++ b/tools/expat/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=expat
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=dd7dab7a5fea97d2a6a43f511449b7cd
+PKG_SOURCE_URL:=@SF/expat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+$(eval $(call HostBuild))