aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-08-06 10:17:16 +0000
committerLuka Perkov <luka@openwrt.org>2013-08-06 10:17:16 +0000
commit38c3bb5bc18ab66acb32360bbccf202b0a5cf2b9 (patch)
tree6ffd873d43f14dfb6988f834aa699e73b3d15972
parenteb8992fc75e7ae5c1255519e60a94e7db4eed469 (diff)
downloadmaster-187ad058-38c3bb5bc18ab66acb32360bbccf202b0a5cf2b9.tar.gz
master-187ad058-38c3bb5bc18ab66acb32360bbccf202b0a5cf2b9.tar.bz2
master-187ad058-38c3bb5bc18ab66acb32360bbccf202b0a5cf2b9.zip
lantiq: add (incomplete) support for Aztech GR7000
*) can not connect to switch chip *) only one usb port is working *) wifi is not working Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37712 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/lantiq/base-files/etc/uci-defaults/02_network6
-rw-r--r--target/linux/lantiq/dts/GR7000.dts135
-rw-r--r--target/linux/lantiq/image/Makefile3
-rw-r--r--target/linux/lantiq/xway/profiles/aztech.mk7
4 files changed, 151 insertions, 0 deletions
diff --git a/target/linux/lantiq/base-files/etc/uci-defaults/02_network b/target/linux/lantiq/base-files/etc/uci-defaults/02_network
index f5401c3edd..6b0093c70b 100755
--- a/target/linux/lantiq/base-files/etc/uci-defaults/02_network
+++ b/target/linux/lantiq/base-files/etc/uci-defaults/02_network
@@ -73,11 +73,17 @@ VG3503J)
ucidef_set_interface_lan 'eth0'
uci set network.lan.type='none'
;;
+
DGN3500*)
ucidef_set_interface_lan "eth0.1"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "3 2 1 0 5t"
;;
+
+GR7000)
+ ucidef_set_interface_wan "eth0"
+ uci set network.lan.ifname=''
+ ;;
esac
[ -z "$(ls /lib/modules/`uname -r`/ltq_atm*)" ] || set_atm_wan "$vpi" "$vci" "$encaps" "$payload"
diff --git a/target/linux/lantiq/dts/GR7000.dts b/target/linux/lantiq/dts/GR7000.dts
new file mode 100644
index 0000000000..6dbd92f867
--- /dev/null
+++ b/target/linux/lantiq/dts/GR7000.dts
@@ -0,0 +1,135 @@
+/dts-v1/;
+
+/include/ "ar9.dtsi"
+
+/ {
+ model = "GR7000 - Aztech GR7000";
+
+ chosen {
+ bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
+ };
+
+ memory@0 {
+ reg = <0x0 0x2000000>;
+ };
+
+ fpi@10000000 {
+ localbus@0 {
+ nor-boot@0 {
+ compatible = "lantiq,nor";
+ bank-width = <2>;
+ reg = <0 0x0 0x2000000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "uboot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "uboot_env";
+ reg = <0x20000 0x10000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "linux";
+ reg = <0x30000 0x7d0000>;
+ };
+ };
+ };
+
+ gpio: pinmux@E100B10 {
+ compatible = "lantiq,pinctrl-xr9";
+ pinctrl-names = "default";
+ pinctrl-0 = <&state_default>;
+
+ state_default: pinmux {
+ stp {
+ lantiq,groups = "stp";
+ lantiq,function = "stp";
+ };
+ pci-in {
+ lantiq,groups = "req1";
+ lantiq,output = <0>;
+ lantiq,open-drain = <1>;
+ lantiq,pull = <2>;
+ };
+ pci-out {
+ lantiq,groups = "gnt1";
+ lantiq,output = <1>;
+ lantiq,pull = <0>;
+ };
+ pci_rst {
+ lantiq,pins = "io21";
+ lantiq,pull = <0>;
+ lantiq,output = <1>;
+ };
+ };
+ };
+
+ ifxhcd@E101000 {
+ status = "okay";
+ };
+
+ pci@E105400 {
+ status = "okay";
+ };
+
+ stp: stp@E100BB0 {
+ compatible = "lantiq,gpio-stp-xway";
+ #gpio-cells = <2>;
+ gpio-controller;
+ reg = <0xE100BB0 0x40>;
+
+ lantiq,shadow = <0xfff>;
+ lantiq,groups = <0x3>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <100>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 53 1>;
+ linux,code = <0x198>;
+ };
+ wps {
+ label = "wps";
+ gpios = <&gpio 54 1>;
+ linux,code = <0x211>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ power2 {
+ label = "power2";
+ gpios = <&stp 4 0>;
+ };
+ internet {
+ label = "internet";
+ gpios = <&stp 2 1>;
+ default-state = "off";
+ };
+ internet2 {
+ label = "internet2";
+ gpios = <&stp 3 1>;
+ };
+ usb {
+ label = "usb";
+ gpios = <&stp 10 1>;
+ };
+ wifi {
+ label = "wifi";
+ gpios = <&stp 15 1>;
+ };
+ };
+};
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 724362ec26..5e97337f52 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -229,6 +229,9 @@ Image/Build/Profile/WBMRB=$(call Image/Build/$(1),$(1),WBMR)
Image/BuildKernel/Profile/FRITZ7320=$(call Image/BuildKernelEVA/Template,FRITZ7320)
Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)
+Image/BuildKernel/Profile/GR7000=$(call Image/BuildKernel/Template,GR7000)
+Image/Build/Profile/GR7000=$(call Image/Build/$(1),$(1),GR7000)
+
# VR9
Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
diff --git a/target/linux/lantiq/xway/profiles/aztech.mk b/target/linux/lantiq/xway/profiles/aztech.mk
new file mode 100644
index 0000000000..3b9e92dc43
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/aztech.mk
@@ -0,0 +1,7 @@
+define Profile/GR7000
+ NAME:=Aztech GR7000
+ PACKAGES:= \
+ kmod-ltq-deu-ar9 kmod-ltq-hcd-ar9 \
+ swconfig
+endef
+$(eval $(call Profile,GR7000))