aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:31:18 +0000
commit372bf44dad630811fa8de131014b2b96d6c505c3 (patch)
tree6dba08faefbebe71ffa4a66e7f108cae8aec9e68
parent345e5cf2cf920fb0e93fbef50317fba826526ddc (diff)
downloadmaster-187ad058-372bf44dad630811fa8de131014b2b96d6c505c3.tar.gz
master-187ad058-372bf44dad630811fa8de131014b2b96d6c505c3.tar.bz2
master-187ad058-372bf44dad630811fa8de131014b2b96d6c505c3.zip
hostapd: work around unconditional libopenssl build dependency
As the OpenWrt build system only resolves build dependencies per directory, all hostapd variants were causing libopenssl to be downloaded and built, not only wpad-mesh. Fix this by applying the same workaround as in ustream-ssl. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46851 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index c16cb11294..c39b6b410d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -177,7 +177,7 @@ endef
define Package/wpad-mesh
$(call Package/wpad/Default)
TITLE+= (with 802.11s mesh and SAE support)
- DEPENDS:=$(DRV_DEPENDS) +libubus +libopenssl +@CONFIG_WPA_SUPPLICANT_OPENSSL @(!TARGET_uml||BROKEN)
+ DEPENDS:=$(DRV_DEPENDS) +libubus +PACKAGE_wpad-mesh:libopenssl +@CONFIG_WPA_SUPPLICANT_OPENSSL @(!TARGET_uml||BROKEN)
CONFLICTS:=@WPA_SUPPLICANT_INTERNAL
VARIANT:=wpad-mesh
endef