aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 14:50:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 14:50:15 +0000
commit32788c07cea73789a3e04e31213505a8931e4436 (patch)
treedcade89f99c43756b3819bcb90044529df847abc
parentd7f2b2cff54773601c6c06b2ed2a5317d1642fe1 (diff)
downloadmaster-187ad058-32788c07cea73789a3e04e31213505a8931e4436.tar.gz
master-187ad058-32788c07cea73789a3e04e31213505a8931e4436.tar.bz2
master-187ad058-32788c07cea73789a3e04e31213505a8931e4436.zip
fix verbose output with dash as /bin/sh
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8227 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Makefile2
-rw-r--r--include/host.mk1
-rw-r--r--include/verbose.mk2
3 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6703d90d61..a039c9880b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,8 @@ ifneq ($(OPENWRT_BUILD),1)
export OPENWRT_BUILD:=1
include $(TOPDIR)/include/toplevel.mk
else
+ include $(TOPDIR)/include/host.mk
+
include rules.mk
include $(INCLUDE_DIR)/depends.mk
include $(INCLUDE_DIR)/subdir.mk
diff --git a/include/host.mk b/include/host.mk
index cc0436e7b0..8b2e56ce51 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -8,6 +8,7 @@
-include $(TMP_DIR)/.host.mk
export TAR
+TMP_DIR ?= $(TOPDIR)/tmp
ifneq ($(__host_inc),1)
__host_inc:=1
diff --git a/include/verbose.mk b/include/verbose.mk
index f18e9a2c71..5ceaf9999c 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -26,7 +26,7 @@ ifeq ($(IS_TTY),1)
endif
define MESSAGE
- echo -e "$(_Y)$(1)$(_N)" >&3
+ /bin/echo -e "$(_Y)$(1)$(_N)" >&3
endef
ifneq ($(KBUILD_VERBOSE),99)