aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-10 16:38:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-10 16:38:05 +0000
commit2d67ccf668b002f65aca256a1bca0816cf4e3749 (patch)
tree872b94730983a12f880284871e6894aa452701da
parent8c18a68c33501b6f2a504d6f7acb2e057d798e07 (diff)
downloadmaster-187ad058-2d67ccf668b002f65aca256a1bca0816cf4e3749.tar.gz
master-187ad058-2d67ccf668b002f65aca256a1bca0816cf4e3749.tar.bz2
master-187ad058-2d67ccf668b002f65aca256a1bca0816cf4e3749.zip
fix docs compile targets
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7905 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Makefile8
-rw-r--r--docs/Makefile4
2 files changed, 7 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index dbfdb8e82e..b798f723c8 100644
--- a/Makefile
+++ b/Makefile
@@ -147,11 +147,11 @@ distclean: dirclean config-clean symlinkclean docclean
help:
cat README
-doc:
- $(MAKE) -C docs/ openwrt.pdf
+docs docs/compile: FORCE
+ $(MAKE) -C docs compile
-docclean:
- $(MAKE) -C docs/ clean
+docs/clean: FORCE
+ $(MAKE) -C docs clean
symlinkclean:
-find package -type l | xargs rm -f
diff --git a/docs/Makefile b/docs/Makefile
index 82381e3169..ffc5bbb062 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -2,13 +2,15 @@ ifeq ($(TOPDIR),)
TOPDIR:=${CURDIR}/..
endif
+all: compile
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/prereq.mk
MAIN = openwrt.tex
DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
-all:
+compile:
$(NO_TRACE_MAKE) cleanup
latex $(MAIN)
$(NO_TRACE_MAKE) openwrt.pdf openwrt.html