aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2010-07-16 09:20:06 +0000
committerHamish Guthrie <hcg@openwrt.org>2010-07-16 09:20:06 +0000
commit2c4ec812d7e35945464dc6f7981c586a0006dc38 (patch)
tree2d109e8e4bc0d58a167147f19ba31ea7836758c6
parentbf9cc3674b60265d8165c258694579ef24a3a1f3 (diff)
downloadmaster-187ad058-2c4ec812d7e35945464dc6f7981c586a0006dc38.tar.gz
master-187ad058-2c4ec812d7e35945464dc6f7981c586a0006dc38.tar.bz2
master-187ad058-2c4ec812d7e35945464dc6f7981c586a0006dc38.zip
Add a profile including Jamvm for Gumstix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22230 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/omap35xx/gumstix/profiles/gsjava.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/omap35xx/gumstix/profiles/gsjava.mk b/target/linux/omap35xx/gumstix/profiles/gsjava.mk
new file mode 100644
index 0000000000..3e3f073464
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/profiles/gsjava.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 - 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gsjava
+ NAME:=gsjava
+ PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+ -firewall -mtd -hotplug2 -udevtrigger \
+ ext2 usb udev kmod-bluetooth ntpclient wpa-supplicant \
+ wireless-tools wpa-cli \
+ bluez-utils bluez-hcidump hegw usbutils python pyserial \
+ python-mini python-openssl python-sqlite3 libstdcpp \
+ kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+ kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+ kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+ crda iw kmod-usb-hid luci luci-app-ntpc jamvm
+endef
+
+define Profile/Gsjava/Description
+ Gumstix including Jamvm Java VM
+endef
+$(eval $(call Profile,Gsjava))