aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-02 15:25:09 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-02 15:25:09 +0000
commit2af13d3e79b67ca471d3538519db68a0b07d250c (patch)
tree3a78385cd48dac83060f428d4db62f94721c1e4f
parentc8bcb7b313b95cdef12aee4fb2d3f7a7b9815d50 (diff)
downloadmaster-187ad058-2af13d3e79b67ca471d3538519db68a0b07d250c.tar.gz
master-187ad058-2af13d3e79b67ca471d3538519db68a0b07d250c.tar.bz2
master-187ad058-2af13d3e79b67ca471d3538519db68a0b07d250c.zip
oxnas/kd20: use gpio-beeper
gpio-beeper module was added to the kernel recently. Make use of it to drive the piezoelectric buzzer of the kd20. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43496 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts9
-rw-r--r--target/linux/oxnas/profiles/100-Generic.mk2
2 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
index e7ee5871c4..9f52f43f80 100644
--- a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
+++ b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-kd20.dts
@@ -123,10 +123,11 @@
label = "kd20:blue:usb";
gpios = <&GPIOB 8 0>;
};
- buzzer {
- label = "kd20:buzzer";
- gpios = <&GPIOB 11 0>;
- };
+ };
+
+ beeper: beeper {
+ compatible = "gpio-beeper";
+ gpios = <&GPIOB 11 0>;
};
gpio-fan {
diff --git a/target/linux/oxnas/profiles/100-Generic.mk b/target/linux/oxnas/profiles/100-Generic.mk
index 734b12376a..d5ec97d44e 100644
--- a/target/linux/oxnas/profiles/100-Generic.mk
+++ b/target/linux/oxnas/profiles/100-Generic.mk
@@ -40,7 +40,7 @@ endef
define Profile/KD20
NAME:=Shuttle KD20
PACKAGES:= \
- uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563
+ uboot-envtools kmod-usb2-oxnas kmod-usb3 kmod-rtc-pcf8563 kmod-gpio-beeper
endef
define Profile/KD20/Description