aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-03-23 22:31:38 +0000
committerLuka Perkov <luka@openwrt.org>2016-03-23 22:31:38 +0000
commit222941dcddc6be6962cd5be1d8ee030fdd439095 (patch)
treef8e2383cc04b4ffeb8b402b2d428775f9079854a
parent0865c11c7b4fd92bd9cb6ac44aed0b2dbb680003 (diff)
downloadmaster-187ad058-222941dcddc6be6962cd5be1d8ee030fdd439095.tar.gz
master-187ad058-222941dcddc6be6962cd5be1d8ee030fdd439095.tar.bz2
master-187ad058-222941dcddc6be6962cd5be1d8ee030fdd439095.zip
ar71xx: add support for ap120c
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49082 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rw-r--r--target/linux/ar71xx/config-4.13
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt8
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-alfa-ap120c.c147
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk14
-rw-r--r--target/linux/ar71xx/image/Makefile2
10 files changed, 179 insertions, 2 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index e88ef3a5ed..bd488a26ff 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -320,6 +320,7 @@ dlan-pro-1200-ac)
ucidef_add_switch_attr "switch0" "enable" "false"
;;
+alfa-ap120c |\
all0305 |\
antminer-s1 |\
antminer-s3 |\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 199379e9fa..f6e38c7aac 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -351,6 +351,9 @@ ar71xx_board_detect() {
*"ALFA Network AP96")
name="alfa-ap96"
;;
+ *"ALFA Network AP120C")
+ name="alfa-ap120c"
+ ;;
*"ALFA Network N2/N5")
name="alfa-nx"
;;
diff --git a/target/linux/ar71xx/config-4.1 b/target/linux/ar71xx/config-4.1
index d740c2e8e8..d6ad85047c 100644
--- a/target/linux/ar71xx/config-4.1
+++ b/target/linux/ar71xx/config-4.1
@@ -29,6 +29,7 @@ CONFIG_ATH79_DEV_NFC=y
CONFIG_ATH79_DEV_SPI=y
CONFIG_ATH79_DEV_USB=y
CONFIG_ATH79_DEV_WMAC=y
+CONFIG_ATH79_MACH_ALFA_AP120C=y
CONFIG_ATH79_MACH_ALFA_AP96=y
CONFIG_ATH79_MACH_ALFA_NX=y
CONFIG_ATH79_MACH_ALL0258N=y
@@ -72,7 +73,6 @@ CONFIG_ATH79_MACH_DLAN_HOTSPOT=y
CONFIG_ATH79_MACH_DLAN_PRO_1200_AC=y
CONFIG_ATH79_MACH_DLAN_PRO_500_WP=y
CONFIG_ATH79_MACH_DR344=y
-CONFIG_ATH79_MACH_GL_DOMINO=y
CONFIG_ATH79_MACH_DRAGINO2=y
CONFIG_ATH79_MACH_EAP300V2=y
CONFIG_ATH79_MACH_EAP7660D=y
@@ -85,6 +85,7 @@ CONFIG_ATH79_MACH_EW_DORIN=y
CONFIG_ATH79_MACH_F9K1115V2=y
CONFIG_ATH79_MACH_GL_AR150=y
CONFIG_ATH79_MACH_GL_AR300=y
+CONFIG_ATH79_MACH_GL_DOMINO=y
CONFIG_ATH79_MACH_GL_INET=y
CONFIG_ATH79_MACH_GS_MINIBOX_V1=y
CONFIG_ATH79_MACH_GS_OOLITE=y
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index b11dd91d83..49cecc5a3f 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -32,6 +32,7 @@ CONFIG_ATH79_DEV_NFC=y
CONFIG_ATH79_DEV_SPI=y
CONFIG_ATH79_DEV_USB=y
CONFIG_ATH79_DEV_WMAC=y
+CONFIG_ATH79_MACH_ALFA_AP120C=y
CONFIG_ATH79_MACH_ALFA_AP96=y
CONFIG_ATH79_MACH_ALFA_NX=y
CONFIG_ATH79_MACH_ALL0258N=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 92e453cd93..4c70c0ab14 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -6,6 +6,14 @@ config ATH79_MACH_ALFA_AP96
select ATH79_DEV_M25P80
select ATH79_DEV_USB
+config ATH79_MACH_ALFA_AP120C
+ bool "ALFA Network AP120C board support"
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_HORNET_UB
bool "ALFA Network Hornet-UB board support"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 021168cb33..0c024c8a08 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += routerboot.o
# Machines
#
obj-$(CONFIG_ATH79_MACH_ALFA_AP96) += mach-alfa-ap96.o
+obj-$(CONFIG_ATH79_MACH_ALFA_AP120C) += mach-alfa-ap120c.o
obj-$(CONFIG_ATH79_MACH_ALFA_NX) += mach-alfa-nx.o
obj-$(CONFIG_ATH79_MACH_ALL0258N) += mach-all0258n.o
obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-alfa-ap120c.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-alfa-ap120c.c
new file mode 100644
index 0000000000..f71275c035
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-alfa-ap120c.c
@@ -0,0 +1,147 @@
+/*
+ * ALFA Network AP120C board support
+ *
+ * Copyright (C) 2012 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (C) 2016 Luka Perkov <luka@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/bitops.h>
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/ar8216_platform.h>
+#include <linux/ath9k_platform.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-ap9x-pci.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define ALFA_AP120C_GPIO_LED 0
+
+#define ALFA_AP120C_GPIO_BUTTON_WIFI 16
+
+#define ALFA_AP120C_GPIO_WATCH_DOG 20
+
+#define ALFA_AP120C_KEYS_POLL_INTERVAL 20 /* msecs */
+#define ALFA_AP120C_KEYS_DEBOUNCE_INTERVAL (3 * ALFA_AP120C_KEYS_POLL_INTERVAL)
+
+#define ALFA_AP120C_MAC_OFFSET 0x1002
+#define ALFA_AP120C_CAL0_OFFSET 0x1000
+
+static struct gpio_keys_button alfa_ap120c_gpio_keys[] __initdata = {
+ {
+ .desc = "Wireless button",
+ .type = EV_KEY,
+ .code = KEY_RFKILL,
+ .debounce_interval = ALFA_AP120C_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = ALFA_AP120C_GPIO_BUTTON_WIFI,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_led alfa_ap120c_leds_gpio[] __initdata = {
+ {
+ .name = "ap120c:red:wlan",
+ .gpio = ALFA_AP120C_GPIO_LED,
+ .active_low = 0,
+ }
+};
+
+static struct ar8327_pad_cfg ap120c_ar8327_pad0_cfg = {
+ .mode = AR8327_PAD_MAC_RGMII,
+ .txclk_delay_en = true,
+ .rxclk_delay_en = true,
+ .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_platform_data ap120c_ar8327_data = {
+ .pad0_cfg = &ap120c_ar8327_pad0_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+};
+
+static struct mdio_board_info ap120c_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &ap120c_ar8327_data,
+ },
+};
+
+static struct flash_platform_data flash __initdata = { NULL, NULL, 0 };
+
+#define ALFA_AP120C_LAN_PHYMASK BIT(5)
+#define ALFA_AP120C_MDIO_PHYMASK ALFA_AP120C_LAN_PHYMASK
+
+static void __init alfa_ap120c_init(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+ u8 mac[ETH_ALEN];
+
+ struct ath9k_platform_data *pdata;
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(alfa_ap120c_leds_gpio),
+ alfa_ap120c_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, ALFA_AP120C_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(alfa_ap120c_gpio_keys),
+ alfa_ap120c_gpio_keys);
+
+ ath79_gpio_function_enable(AR71XX_GPIO_FUNC_SPI_CS1_EN |
+ AR71XX_GPIO_FUNC_SPI_CS2_EN);
+
+ ath79_register_m25p80_multi(&flash);
+
+ ath79_init_mac(mac, art + ALFA_AP120C_MAC_OFFSET, 1);
+ ath79_register_wmac(art + ALFA_AP120C_CAL0_OFFSET, mac);
+
+ ath79_init_mac(mac, art + ALFA_AP120C_MAC_OFFSET, 2);
+ ap91_pci_init(NULL, mac);
+ pdata = ap9x_pci_get_wmac_data(0);
+ if (!pdata) {
+ pr_err("ap120c: unable to get address of wlan data\n");
+ return;
+ }
+ pdata->use_eeprom = true;
+
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0 |
+ BIT(15) | BIT(17) | BIT(19) | BIT(21));
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + ALFA_AP120C_MAC_OFFSET, 0);
+
+ mdiobus_register_board_info(ap120c_mdio0_info, ARRAY_SIZE(ap120c_mdio0_info));
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = ALFA_AP120C_LAN_PHYMASK;
+
+ ath79_eth0_pll_data.pll_1000 = 0x42000000;
+ ath79_eth0_pll_data.pll_10 = 0x00001313;
+
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+ ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_ALFA_AP120C, "ALFA-AP120C", "ALFA Network AP120C",
+ alfa_ap120c_init);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index e63e71762b..43e2897231 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -18,6 +18,7 @@ enum ath79_mach_type {
ATH79_MACH_GENERIC_OF = -1, /* Device tree board */
ATH79_MACH_GENERIC = 0,
ATH79_MACH_ALFA_AP96, /* ALFA Network AP96 board */
+ ATH79_MACH_ALFA_AP120C, /* ALFA Network AP120 board */
ATH79_MACH_ALFA_NX, /* ALFA Network N2/N5 board */
ATH79_MACH_ALL0258N, /* Allnet ALL0258N */
ATH79_MACH_ALL0305, /* Allnet ALL0305 */
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
index 6e259dc602..ae82fb704d 100644
--- a/target/linux/ar71xx/generic/profiles/alfa.mk
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -1,10 +1,22 @@
#
-# Copyright (C) 2011-2013 OpenWrt.org
+# Copyright (C) 2011-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+define Profile/ALFAAP120C
+ NAME:=ALFA Network AP120C board
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALFAAP120C/Description
+ Package set optimized for the ALFA Network AP120C board
+endef
+
+$(eval $(call Profile,ALFAAP120C))
+
+
define Profile/ALFAAP96
NAME:=ALFA Network AP96 board
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0af6de1a81..7747df57c3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1557,6 +1557,7 @@ define Build/Clean
endef
alfa_ap96_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13312k(rootfs),2048k(kernel),512k(caldata)ro,15360k@0x80000(firmware)
+alfa_ap120c_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,13312k(rootfs),1536k(kernel),1152k(unknown)ro,64k(art)ro;spi0.1:-(unknown)
alfa_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1600k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro
all0258n_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),6272k(firmware),1536k(failsafe),64k(art)
@@ -2357,6 +2358,7 @@ $(eval $(call SingleProfile,AthGzip,64k,AP96,ap96,AP96,ttyS0,115200,$$(ap96_mtdl
$(eval $(call SingleProfile,AthGzip,64k,WNDAP360,wndap360,WNDAP360,ttyS0,9600,$$(wndap360_mtdlayout),KRuImage))
$(eval $(call SingleProfile,AthLzma,64k,ALFAAP96,alfa-ap96,ALFA-AP96,ttyS0,115200,$$(alfa_ap96_mtdlayout),RKuImage))
+$(eval $(call SingleProfile,AthLzma,64k,ALFAAP120C,alfa-ap120c,ALFA-AP120C,ttyS0,115200,$$(alfa_ap120c_mtdlayout),RKuImage))
$(eval $(call SingleProfile,AthLzma,64k,ALL0258N,all0258n,ALL0258N,ttyS0,115200,$$(all0258n_mtdlayout),KRuImage,65536))
$(eval $(call SingleProfile,AthLzma,256k,ALL0315N,all0315n,ALL0315N,ttyS0,115200,$$(all0315n_mtdlayout),KRuImage,262144))
$(eval $(call SingleProfile,AthLzma,64k,AP113,ap113,AP113,ttyS0,115200,$$(ap113_mtd_layout),RK))