aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-11 08:04:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-11 08:04:48 +0000
commit207e5d51075d33d05f99e3fce09c49fb4f07ee6a (patch)
tree052e26794344c493ae0264522b8bc274f0c12705
parent5026c20927235331672bf55efdf73403be05dbc2 (diff)
downloadmaster-187ad058-207e5d51075d33d05f99e3fce09c49fb4f07ee6a.tar.gz
master-187ad058-207e5d51075d33d05f99e3fce09c49fb4f07ee6a.tar.bz2
master-187ad058-207e5d51075d33d05f99e3fce09c49fb4f07ee6a.zip
ar71xx: add profile and build image for the TL-WA750RE TL-WA850RE range extender
Patch to add profile and build image for the tplink TL-WA750RE/WA850RE board Signed-off-by: Martijn Zilverschoon <thefriedzombie@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38719 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk23
-rw-r--r--target/linux/ar71xx/image/Makefile2
2 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index b7d4ec01ad..5236f7fd2b 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -139,6 +139,18 @@ define Profile/TLWA701/Description
endef
$(eval $(call Profile,TLWA701))
+
+define Profile/TLWA750
+ NAME:=TP-LINK TL-WA750RE
+ PACKAGES:=
+endef
+
+define Profile/TLWA750/Description
+ Package set optimized for the TP-LINK TL-WA750RE.
+endef
+$(eval $(call Profile,TLWA750))
+
+
define Profile/TLWA7510
NAME:=TP-LINK TL-WA7510N
PACKAGES:=
@@ -170,6 +182,17 @@ endef
$(eval $(call Profile,TLWA830))
+define Profile/TLWA850
+ NAME:=TP-LINK TL-WA850RE
+ PACKAGES:=
+endef
+
+define Profile/TLWA850/Description
+ Package set optimized for the TP-LINK TL-WA850RE.
+endef
+$(eval $(call Profile,TLWA850))
+
+
define Profile/TLWA901
NAME:=TP-LINK TL-WA901N/ND
PACKAGES:=
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 897aab9ba6..3af8375a8c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -996,7 +996,9 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR720NV3,tl-wr720n-v3,TL-WR720N
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR740NV4,tl-wr740n-v4,TL-WR741ND-v4,ttyATH0,115200,0x07400004,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR741NV4,tl-wr741nd-v4,TL-WR741ND-v4,ttyATH0,115200,0x07410004,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR743NV2,tl-wr743nd-v2,TL-WR741ND-v4,ttyATH0,115200,0x07430002,1,4Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA750,tl-wa750re-v1,TL-WA750RE,ttyS0,115200,0x07500001,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR841NV8,tl-wr841n-v8,TL-WR841N-v8,ttyS0,115200,0x08410008,1,4Mlzma))
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWA850,tl-wa850re-v1,TL-WA850RE,ttyS0,115200,0x08500001,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR941NV6,tl-wr941nd-v6,TL-WDR3500,ttyS0,115200,0x09410006,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR1041,tl-wr1041n-v2,TL-WR1041N-v2,ttyS0,115200,0x10410002,1,4Mlzma))
$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWR2543,tl-wr2543-v1,TL-WR2543N,ttyS0,115200,0x25430001,1,8Mlzma,-v 3.13.99))