aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-26 00:52:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-26 00:52:51 +0000
commit1cc29eb1c1726159951c978a2918dbb5ce1591da (patch)
tree890291126842e163efa99e91022a2b1adc1ff113
parent93dbc52b0bd6a4af1ab5f5c777a34e29696884ba (diff)
downloadmaster-187ad058-1cc29eb1c1726159951c978a2918dbb5ce1591da.tar.gz
master-187ad058-1cc29eb1c1726159951c978a2918dbb5ce1591da.tar.bz2
master-187ad058-1cc29eb1c1726159951c978a2918dbb5ce1591da.zip
minor cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6381 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/alsa/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/package/alsa/Makefile b/package/alsa/Makefile
index 8aa80e74a5..347ef76276 100644
--- a/package/alsa/Makefile
+++ b/package/alsa/Makefile
@@ -46,21 +46,18 @@ ifeq ($(LINUX_KARCH),mips)
KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
endif
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- CFLAGS="$(KERNEL_C_INCS)" \
- ./configure \
- --with-build="$(LINUX_DIR)" \
- --with-kernel="$(LINUX_DIR)" \
- --with-cross="$(KERNEL_CROSS)" \
- --with-redhat=no \
- --with-suse=no \
- --with-oss=yes \
- --with-isapnp=no \
- --with-sequencer=no \
- --with-cards=usb-audio \
- );
-endef
+CONFIGURE_VARS:= \
+ CFLAGS="$(KERNEL_C_INCS)"
+
+CONFIGURE_ARGS:= \
+ --with-build="$(LINUX_DIR)" \
+ --with-kernel="$(LINUX_DIR)" \
+ --with-redhat=no \
+ --with-suse=no \
+ --with-oss=yes \
+ --with-isapnp=no \
+ --with-sequencer=no \
+ --with-cards=usb-audio
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \