aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 02:41:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 02:41:59 +0000
commit1b8b054bfc216cf0662555afdcc34d770d64720a (patch)
tree7d73f27bb01f4907adae2f423afe87357e50303a
parent39968194002433a9e0313e4189585f31abeacaf7 (diff)
downloadmaster-187ad058-1b8b054bfc216cf0662555afdcc34d770d64720a.tar.gz
master-187ad058-1b8b054bfc216cf0662555afdcc34d770d64720a.tar.bz2
master-187ad058-1b8b054bfc216cf0662555afdcc34d770d64720a.zip
fix another build error
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5508 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/host.mk5
-rw-r--r--include/prereq-build.mk1
2 files changed, 3 insertions, 3 deletions
diff --git a/include/host.mk b/include/host.mk
index 1130d5b9a6..278ad726ff 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -9,9 +9,9 @@ include $(TMP_DIR)/.host.mk
export TAR
-$(TMP_DIR)/.host.mk: $(INCLUDE_DIR)/host.mk
+$(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
+ @mkdir -p $(TMP_DIR)
@( \
- echo -n "BASH:=$(shell which bash)"; \
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
@@ -29,5 +29,6 @@ $(TMP_DIR)/.host.mk: $(INCLUDE_DIR)/host.mk
ZCAT=`which gzcat`; \
[ -n "$$ZCAT" -a -x "$$ZCAT" ] || ZCAT=`which zcat`; \
echo "ZCAT:=$$ZCAT" >> $@; \
+ echo "BASH:=$(shell which bash)" >> $@; \
)
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 10bc68ae15..ed8fdb6fce 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -6,7 +6,6 @@
#
include $(TOPDIR)/rules.mk
-TMP_DIR:=$(TOPDIR)/tmp
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/host.mk