aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-07-11 19:58:44 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-07-11 19:58:44 +0000
commit18748aea45fab91571285ad03b6a507deafad421 (patch)
tree19ec7cf9cf31f3a0c857938d94130d58b159cb3d
parent5da5af14ddffb02d4f181e92f240a7de7cca321c (diff)
downloadmaster-187ad058-18748aea45fab91571285ad03b6a507deafad421.tar.gz
master-187ad058-18748aea45fab91571285ad03b6a507deafad421.tar.bz2
master-187ad058-18748aea45fab91571285ad03b6a507deafad421.zip
kernel: update 3.18 to 3.18.18
Changelog: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.18 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46299 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch10
-rw-r--r--target/linux/generic/patches-3.18/091-mtd-spi-nor-add-support-Spansion_S25FL164K8
-rw-r--r--target/linux/generic/patches-3.18/099-module_arch_freeing_init-new-hook-for-archs-before-m.patch12
-rw-r--r--target/linux/generic/patches-3.18/204-module_strip.patch4
-rw-r--r--target/linux/generic/patches-3.18/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch2
-rw-r--r--target/linux/generic/patches-3.18/630-packet_socket_type.patch16
-rw-r--r--target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch24
-rw-r--r--target/linux/generic/patches-3.18/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch6
12 files changed, 45 insertions, 47 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index a07115ea28..4227e01866 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,11 +2,11 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .17
+LINUX_VERSION-3.18 = .18
LINUX_VERSION-4.0 = .7
LINUX_VERSION-4.1 = .1
-LINUX_KERNEL_MD5SUM-3.18.17 = f05d7620c587d8b0ab3cd944ff9dc9f7
+LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
LINUX_KERNEL_MD5SUM-4.0.7 = 7993e5389c189d5c7dbc21135aebc0c1
LINUX_KERNEL_MD5SUM-4.1.1 = bf83da42349ab7fe77c61b5d10d9f003
diff --git a/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch b/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
index c899c10cff..f7f88f8134 100644
--- a/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
+++ b/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
@@ -26,7 +26,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/net/bridge/br_multicast.c
+++ b/net/bridge/br_multicast.c
-@@ -1949,11 +1949,9 @@ out:
+@@ -1948,11 +1948,9 @@ out:
int br_multicast_set_router(struct net_bridge *br, unsigned long val)
{
@@ -39,7 +39,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
switch (val) {
case 0:
-@@ -1964,13 +1962,8 @@ int br_multicast_set_router(struct net_b
+@@ -1963,13 +1961,8 @@ int br_multicast_set_router(struct net_b
br->multicast_router = val;
err = 0;
break;
@@ -53,7 +53,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
spin_unlock_bh(&br->multicast_lock);
return err;
-@@ -1979,11 +1972,9 @@ unlock:
+@@ -1978,11 +1971,9 @@ unlock:
int br_multicast_set_port_router(struct net_bridge_port *p, unsigned long val)
{
struct net_bridge *br = p->br;
@@ -66,7 +66,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
switch (val) {
case 0:
-@@ -2005,13 +1996,8 @@ int br_multicast_set_port_router(struct
+@@ -2004,13 +1995,8 @@ int br_multicast_set_port_router(struct
br_multicast_add_router(br, p);
break;
@@ -80,7 +80,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
spin_unlock(&br->multicast_lock);
return err;
-@@ -2116,15 +2102,11 @@ unlock:
+@@ -2115,15 +2101,11 @@ unlock:
int br_multicast_set_hash_max(struct net_bridge *br, unsigned long val)
{
diff --git a/target/linux/generic/patches-3.18/091-mtd-spi-nor-add-support-Spansion_S25FL164K b/target/linux/generic/patches-3.18/091-mtd-spi-nor-add-support-Spansion_S25FL164K
index 354bd7815f..d9831f4e71 100644
--- a/target/linux/generic/patches-3.18/091-mtd-spi-nor-add-support-Spansion_S25FL164K
+++ b/target/linux/generic/patches-3.18/091-mtd-spi-nor-add-support-Spansion_S25FL164K
@@ -1,8 +1,6 @@
-Index: linux-3.18.17/drivers/mtd/spi-nor/spi-nor.c
-===================================================================
---- linux-3.18.17.orig/drivers/mtd/spi-nor/spi-nor.c
-+++ linux-3.18.17/drivers/mtd/spi-nor/spi-nor.c
-@@ -570,6 +570,7 @@ static const struct spi_device_id spi_no
+--- a/drivers/mtd/spi-nor/spi-nor.c
++++ b/drivers/mtd/spi-nor/spi-nor.c
+@@ -566,6 +566,7 @@ static const struct spi_device_id spi_no
{ "s25fl008k", INFO(0xef4014, 0, 64 * 1024, 16, SECT_4K) },
{ "s25fl016k", INFO(0xef4015, 0, 64 * 1024, 32, SECT_4K) },
{ "s25fl064k", INFO(0xef4017, 0, 64 * 1024, 128, SECT_4K) },
diff --git a/target/linux/generic/patches-3.18/099-module_arch_freeing_init-new-hook-for-archs-before-m.patch b/target/linux/generic/patches-3.18/099-module_arch_freeing_init-new-hook-for-archs-before-m.patch
index 05cb2585ed..d00f751cdc 100644
--- a/target/linux/generic/patches-3.18/099-module_arch_freeing_init-new-hook-for-archs-before-m.patch
+++ b/target/linux/generic/patches-3.18/099-module_arch_freeing_init-new-hook-for-archs-before-m.patch
@@ -122,7 +122,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
+ mod->arch.syminfo = NULL;
}
- static void
+ static void check_rela(Elf_Rela *rela, struct module *me)
--- a/arch/tile/kernel/module.c
+++ b/arch/tile/kernel/module.c
@@ -83,7 +83,7 @@ void module_free(struct module *mod, voi
@@ -136,7 +136,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
}
--- a/include/linux/moduleloader.h
+++ b/include/linux/moduleloader.h
-@@ -80,4 +80,6 @@ int module_finalize(const Elf_Ehdr *hdr,
+@@ -82,4 +82,6 @@ int module_finalize(const Elf_Ehdr *hdr,
/* Any cleanup needed when module leaves. */
void module_arch_cleanup(struct module *mod);
@@ -145,7 +145,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
#endif
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -1855,6 +1855,10 @@ void __weak module_arch_cleanup(struct m
+@@ -1833,6 +1833,10 @@ void __weak module_arch_cleanup(struct m
{
}
@@ -156,7 +156,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
/* Free a module, remove from lists, etc. */
static void free_module(struct module *mod)
{
-@@ -1880,6 +1884,7 @@ static void free_module(struct module *m
+@@ -1865,6 +1869,7 @@ static void free_module(struct module *m
/* This may be NULL, but that's OK */
unset_module_init_ro_nx(mod);
@@ -164,7 +164,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
module_free(mod, mod->module_init);
kfree(mod->args);
percpu_modfree(mod);
-@@ -2983,6 +2988,7 @@ out:
+@@ -2954,6 +2959,7 @@ static struct module *layout_and_allocat
static void module_deallocate(struct module *mod, struct load_info *info)
{
percpu_modfree(mod);
@@ -172,7 +172,7 @@ Origin: backport, https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
module_free(mod, mod->module_init);
module_free(mod, mod->module_core);
}
-@@ -3122,6 +3128,7 @@ static int do_init_module(struct module
+@@ -3077,6 +3083,7 @@ static int do_init_module(struct module
mod->strtab = mod->core_strtab;
#endif
unset_module_init_ro_nx(mod);
diff --git a/target/linux/generic/patches-3.18/204-module_strip.patch b/target/linux/generic/patches-3.18/204-module_strip.patch
index ed95eafd0d..09bffe0673 100644
--- a/target/linux/generic/patches-3.18/204-module_strip.patch
+++ b/target/linux/generic/patches-3.18/204-module_strip.patch
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
config INIT_ALL_POSSIBLE
--- a/kernel/module.c
+++ b/kernel/module.c
-@@ -2665,6 +2665,7 @@ static struct module *setup_load_info(st
+@@ -2670,6 +2670,7 @@ static struct module *setup_load_info(st
static int check_modinfo(struct module *mod, struct load_info *info, int flags)
{
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
const char *modmagic = get_modinfo(info, "vermagic");
int err;
-@@ -2690,6 +2691,7 @@ static int check_modinfo(struct module *
+@@ -2695,6 +2696,7 @@ static int check_modinfo(struct module *
pr_warn("%s: module is from the staging directory, the quality "
"is unknown, you have been warned.\n", mod->name);
}
diff --git a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
index 44548ca8cc..63c85dd40a 100644
--- a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
@@ -71,7 +71,7 @@
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/of.h>
-@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
+@@ -2630,3 +2631,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
diff --git a/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch b/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
index 6bf516c71b..dca6895c14 100644
--- a/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
+++ b/target/linux/generic/patches-3.18/472-mtd-m25p80-add-support-for-Winbond-W25X05-flash.patch
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/drivers/mtd/spi-nor/spi-nor.c
+++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -616,6 +616,7 @@ static const struct spi_device_id spi_no
+@@ -617,6 +617,7 @@ static const struct spi_device_id spi_no
{ "m25px80", INFO(0x207114, 0, 64 * 1024, 16, 0) },
/* Winbond -- w25x "blocks" are 64K, "sectors" are 4KiB */
diff --git a/target/linux/generic/patches-3.18/630-packet_socket_type.patch b/target/linux/generic/patches-3.18/630-packet_socket_type.patch
index 06bd167abf..fa057b264d 100644
--- a/target/linux/generic/patches-3.18/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.18/630-packet_socket_type.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
-@@ -1530,6 +1530,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1516,6 +1516,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* When we registered the protocol we saved the socket in the data
-@@ -1537,6 +1538,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1523,6 +1524,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* Yank back the headers [hope the device set this
-@@ -1549,7 +1551,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1535,7 +1537,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1756,12 +1758,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -1742,12 +1744,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -1881,12 +1883,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -1867,12 +1869,12 @@ static int tpacket_rcv(struct sk_buff *s
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2823,6 +2825,7 @@ static int packet_create(struct net *net
+@@ -2809,6 +2811,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3403,6 +3406,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3389,6 +3392,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3454,6 +3467,13 @@ static int packet_getsockopt(struct sock
+@@ -3440,6 +3453,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
index a7e320f8a0..00ad14f113 100644
--- a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
@@ -133,7 +133,7 @@
if (err)
break;
}
-@@ -1407,7 +1434,8 @@ br_multicast_leave_group(struct net_brid
+@@ -1406,7 +1433,8 @@ br_multicast_leave_group(struct net_brid
struct net_bridge_port *port,
struct br_ip *group,
struct bridge_mcast_other_query *other_query,
@@ -143,7 +143,7 @@
{
struct net_bridge_mdb_htable *mdb;
struct net_bridge_mdb_entry *mp;
-@@ -1457,7 +1485,7 @@ br_multicast_leave_group(struct net_brid
+@@ -1456,7 +1484,7 @@ br_multicast_leave_group(struct net_brid
for (pp = &mp->ports;
(p = mlock_dereference(*pp, br)) != NULL;
pp = &p->next) {
@@ -152,7 +152,7 @@
continue;
rcu_assign_pointer(*pp, p->next);
-@@ -1491,7 +1519,7 @@ br_multicast_leave_group(struct net_brid
+@@ -1490,7 +1518,7 @@ br_multicast_leave_group(struct net_brid
for (p = mlock_dereference(mp->ports, br);
p != NULL;
p = mlock_dereference(p->next, br)) {
@@ -161,7 +161,7 @@
continue;
if (!hlist_unhashed(&p->mglist) &&
-@@ -1509,8 +1537,8 @@ out:
+@@ -1508,8 +1536,8 @@ out:
static void br_ip4_multicast_leave_group(struct net_bridge *br,
struct net_bridge_port *port,
@@ -172,7 +172,7 @@
{
struct br_ip br_group;
struct bridge_mcast_own_query *own_query;
-@@ -1525,14 +1553,14 @@ static void br_ip4_multicast_leave_group
+@@ -1524,14 +1552,14 @@ static void br_ip4_multicast_leave_group
br_group.vid = vid;
br_multicast_leave_group(br, port, &br_group, &br->ip4_other_query,
@@ -189,7 +189,7 @@
{
struct br_ip br_group;
struct bridge_mcast_own_query *own_query;
-@@ -1547,7 +1575,7 @@ static void br_ip6_multicast_leave_group
+@@ -1546,7 +1574,7 @@ static void br_ip6_multicast_leave_group
br_group.vid = vid;
br_multicast_leave_group(br, port, &br_group, &br->ip6_other_query,
@@ -198,7 +198,7 @@
}
#endif
-@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1555,6 +1583,7 @@ static int br_multicast_ipv4_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -206,7 +206,7 @@
struct sk_buff *skb2 = skb;
const struct iphdr *iph;
struct igmphdr *ih;
-@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1628,7 +1657,7 @@ static int br_multicast_ipv4_rcv(struct
case IGMP_HOST_MEMBERSHIP_REPORT:
case IGMPV2_HOST_MEMBERSHIP_REPORT:
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -215,7 +215,7 @@
break;
case IGMPV3_HOST_MEMBERSHIP_REPORT:
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1637,7 +1666,7 @@ static int br_multicast_ipv4_rcv(struct
err = br_ip4_multicast_query(br, port, skb2, vid);
break;
case IGMP_HOST_LEAVE_MESSAGE:
@@ -224,7 +224,7 @@
break;
}
-@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1655,6 +1684,7 @@ static int br_multicast_ipv6_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -232,7 +232,7 @@
struct sk_buff *skb2;
const struct ipv6hdr *ip6h;
u8 icmp6_type;
-@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1764,7 +1794,8 @@ static int br_multicast_ipv6_rcv(struct
}
mld = (struct mld_msg *)skb_transport_header(skb2);
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -242,7 +242,7 @@
break;
}
case ICMPV6_MLD2_REPORT:
-@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1781,7 +1812,7 @@ static int br_multicast_ipv6_rcv(struct
goto out;
}
mld = (struct mld_msg *)skb_transport_header(skb2);
diff --git a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
index f8bc1f44ed..b8fbe92378 100644
--- a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1693,27 +1693,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1690,27 +1690,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch b/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
index 42bddfee35..d20fc04cb0 100644
--- a/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
@@ -15,7 +15,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -914,6 +914,9 @@ int genphy_update_link(struct phy_device
+@@ -915,6 +915,9 @@ int genphy_update_link(struct phy_device
{
int status;
diff --git a/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch b/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
index c2554158e3..0350f9efe4 100644
--- a/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
+++ b/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1132,7 +1132,7 @@ int genphy_config_init(struct phy_device
+@@ -1133,7 +1133,7 @@ int genphy_config_init(struct phy_device
return 0;
}
@@ -9,7 +9,7 @@
{
/* Do nothing for now */
return 0;
-@@ -1346,7 +1346,7 @@ static struct phy_driver genphy_driver[]
+@@ -1347,7 +1347,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic PHY",
@@ -18,7 +18,7 @@
.config_init = genphy_config_init,
.features = PHY_GBIT_FEATURES | SUPPORTED_MII |
SUPPORTED_AUI | SUPPORTED_FIBRE |
-@@ -1361,7 +1361,7 @@ static struct phy_driver genphy_driver[]
+@@ -1362,7 +1362,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic 10G PHY",