aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
commit13f7fb3995c81f1e2c43c7969beb8cc34515efe3 (patch)
tree72af00ce1b265cac00e13f64356a20708e3a4aff
parent96e0e6c808daf5cc22fbc2fd6247b9611837cbbe (diff)
downloadmaster-187ad058-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.tar.gz
master-187ad058-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.tar.bz2
master-187ad058-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.zip
disable package that can't build on atheros target (no pci/usb)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8823 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/other.mk5
-rw-r--r--package/rt2x00/Makefile3
2 files changed, 6 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 8644d89ce2..9b5bc6d467 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -92,9 +92,11 @@ endef
$(eval $(call KernelPackage,lp))
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
define KernelPackage/soundcore
SUBMENU:=$(OTHER_MENU)
TITLE:=Sound support
+ DEPENDS:=@PCI_SUPPORT||USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_SOUND \
CONFIG_SND \
@@ -238,10 +240,11 @@ endef
$(eval $(call KernelPackage,pcmcia-serial))
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT
+ DEPENDS:=@USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
diff --git a/package/rt2x00/Makefile b/package/rt2x00/Makefile
index a6c7e5c86b..71cd418be8 100644
--- a/package/rt2x00/Makefile
+++ b/package/rt2x00/Makefile
@@ -25,10 +25,11 @@ ifeq ($(DUMP),)
include $(LINUX_DIR)/.config
endif
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
define KernelPackage/rt2x00/Default
SUBMENU:=Wireless Drivers
TITLE:=Ralink Drivers for RT2x00 cards
- DEPENDS:=@LINUX_2_6
+ DEPENDS:=@LINUX_2_6 @!TARGET_atheros
KCONFIG:=CONFIG_MAC80211
endef