aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-25 18:33:33 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-25 18:33:33 +0000
commit0feab05a266c13f97a71029d2e1a22825fcb612d (patch)
tree7943929f7dec69baae16bf100caaa0fe55950bf9
parentcd2a054229ff56d2586f338664771d5bfc25faf7 (diff)
downloadmaster-187ad058-0feab05a266c13f97a71029d2e1a22825fcb612d.tar.gz
master-187ad058-0feab05a266c13f97a71029d2e1a22825fcb612d.tar.bz2
master-187ad058-0feab05a266c13f97a71029d2e1a22825fcb612d.zip
fix lzma uImage generation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13351 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/avr32/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index c74efbe1df..692c325b5e 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -25,7 +25,7 @@ endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ $(STAGING_DIR_HOST)/bin/lzma e $(LINUX_DIR)/arch/avr32/boot/images/vmlinux.bin $(KDIR)/vmlinux.lzma
mkimage -A avr32 -O linux -T kernel -a 0x10000000 -C lzma \
-e 0x90000000 \
-n 'OpenWrt Linux-$(LINUX_VERSION)' \