aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-04 17:41:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-04 17:41:23 +0000
commit0e41af577f6792aeabb0913f71a19cd61c80402d (patch)
treef667ff8080abde4b803b68325d50413968d185e8
parent32d1003a5d3b2c34e8ddf73841144a471c7e1355 (diff)
downloadmaster-187ad058-0e41af577f6792aeabb0913f71a19cd61c80402d.tar.gz
master-187ad058-0e41af577f6792aeabb0913f71a19cd61c80402d.tar.bz2
master-187ad058-0e41af577f6792aeabb0913f71a19cd61c80402d.zip
mac80211: add dependency of PACKAGE_MAC80211_DEBUGFS
I wanted to use some statistics from /sys/kernel/debug/ieee80211, so I enabled PACKAGE_MAC80211_DEBUGFS. But I could not use it, because CONFIG_KERNEL_DEBUG_FS was not set and it's a little bit hidden. After manually setting CONFIG_KERNEL_DEBUG_FS to y, everything was fine. This patch automatically selects CONFIG_KERNEL_DEBUG_FS if PACKAGE_MAC80211_DEBUGFS is set. Additionally, the help text says "Say N unless you know you need this.", but it's default y. This help text is copied verbatim from the kernel's Kconfig and not true for us. So remove this part of the help text Signed-off-by: Stefan Hellermann <stefan@the2masters.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35014 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/mac80211/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index f57d30353c..ac60193624 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -84,13 +84,12 @@ define KernelPackage/mac80211/config
config PACKAGE_MAC80211_DEBUGFS
bool "Export mac80211 internals in DebugFS"
+ select KERNEL_DEBUG_FS
default y
help
Select this to see extensive information about
the internal state of mac80211 in debugfs.
- Say N unless you know you need this.
-
config PACKAGE_MAC80211_MESH
bool "Enable 802.11s mesh support"
default y