aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo Croce <matteo.croce@canonical.com>2016-06-22 15:15:10 +0200
committerMatteo Croce <matteo.croce@canonical.com>2016-06-22 16:13:21 +0200
commit080fabb5c7758df606cea194d49a39b2711aa708 (patch)
tree6c742641c4ecfe70c688b9ca3f1492b8d2338a0b
parentd7863315dd05777620fd133bb6880674fd3a00bd (diff)
downloadmaster-187ad058-080fabb5c7758df606cea194d49a39b2711aa708.tar.gz
master-187ad058-080fabb5c7758df606cea194d49a39b2711aa708.tar.bz2
master-187ad058-080fabb5c7758df606cea194d49a39b2711aa708.zip
add plan 9 fs support
9pfs is used by kvm to share files between host and guest, add proper config option to enable it.
-rw-r--r--package/kernel/linux/modules/fs.mk19
-rw-r--r--package/kernel/linux/modules/netsupport.mk21
-rw-r--r--target/linux/x86/kvm_guest/target.mk2
3 files changed, 41 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index a47eea909d..4eb5e3ee99 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -26,6 +26,25 @@ endef
$(eval $(call KernelPackage,fs-fscache))
+define KernelPackage/fs-9p
+ SUBMENU:=$(FS_MENU)
+ TITLE:=Plan 9 Resource Sharing Support
+ DEFAULT:=n
+ DEPENDS:=+kmod-9pnet
+ KCONFIG:=\
+ CONFIG_9P_FS=m \
+ CONFIG_9P_FS_POSIX_ACL=n \
+ CONFIG_9P_FS_SECURITY=n
+ FILES:=$(LINUX_DIR)/fs/9p/9p.ko
+ AUTOLOAD:=$(call AutoLoad,30,9p)
+endef
+
+define KernelPackage/fs-9p/description
+ Kernel module for Plan 9 Resource Sharing Support support
+endef
+
+$(eval $(call KernelPackage,fs-9p))
+
define KernelPackage/fs-afs
SUBMENU:=$(FS_MENU)
TITLE:=Andrew FileSystem client
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 09fa5951ff..538520b2bf 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1024,3 +1024,24 @@ define KernelPackage/mpls/description
endef
$(eval $(call KernelPackage,mpls))
+
+define KernelPackage/9pnet
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Plan 9 Resource Sharing Support (9P2000)
+ DEPENDS:=@PCI_SUPPORT
+ KCONFIG:= \
+ CONFIG_NET_9P=m \
+ CONFIG_NET_9P_DEBUG=n \
+ CONFIG_NET_9P_VIRTIO=m
+ FILES:= \
+ $(LINUX_DIR)/net/9p/9pnet.ko \
+ $(LINUX_DIR)/net/9p/9pnet_virtio.ko
+ AUTOLOAD:=$(call AutoLoad,29,9pnet 9pnet_virtio)
+endef
+
+define KernelPackage/9pnet/description
+ Kernel support support for
+ Plan 9 resource sharing via the 9P2000 protocol.
+endef
+
+$(eval $(call KernelPackage,9pnet))
diff --git a/target/linux/x86/kvm_guest/target.mk b/target/linux/x86/kvm_guest/target.mk
index 9970d73277..9ebb66a5fc 100644
--- a/target/linux/x86/kvm_guest/target.mk
+++ b/target/linux/x86/kvm_guest/target.mk
@@ -1,4 +1,4 @@
BOARDNAME:=KVM Guest
FEATURES:=ext4 pci usb
-DEFAULT_PACKAGES += kmod-button-hotplug kmod-virtio-balloon kmod-virtio-net kmod-virtio-random
+DEFAULT_PACKAGES += kmod-button-hotplug kmod-virtio-balloon kmod-virtio-net kmod-virtio-random kmod-fs-9p
CPU_TYPE := pentium4