aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-18 05:38:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-18 05:38:44 +0000
commit0308066752fe8732e913a422031d93e2a4dacd87 (patch)
tree660a45e5512161ca80800d0546f605d105a883eb
parent7c8e92210d2ff0dc6a22b921e53ee14676f81636 (diff)
downloadmaster-187ad058-0308066752fe8732e913a422031d93e2a4dacd87.tar.gz
master-187ad058-0308066752fe8732e913a422031d93e2a4dacd87.tar.bz2
master-187ad058-0308066752fe8732e913a422031d93e2a4dacd87.zip
[package] base-files: disable bridge firewalling by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19214 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/Makefile4
-rw-r--r--package/base-files/files/etc/sysctl.conf7
2 files changed, 8 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index ea2b5a47f1..fb30b94ab9 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=35
+PKG_RELEASE:=36
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/etc/sysctl.conf b/package/base-files/files/etc/sysctl.conf
index 63497beb1c..759752ae5e 100644
--- a/package/base-files/files/etc/sysctl.conf
+++ b/package/base-files/files/etc/sysctl.conf
@@ -4,7 +4,7 @@ net.ipv4.conf.all.arp_ignore=1
net.ipv4.ip_forward=1
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.icmp_ignore_bogus_error_responses=1
-net.ipv4.tcp_ecn=0
+net.ipv4.tcp_ecn=0
net.ipv4.tcp_fin_timeout=30
net.ipv4.tcp_keepalive_time=120
net.ipv4.tcp_syncookies=1
@@ -17,3 +17,8 @@ net.ipv4.netfilter.ip_conntrack_tcp_timeout_established=3600
net.ipv4.netfilter.ip_conntrack_udp_timeout=60
net.ipv4.netfilter.ip_conntrack_udp_timeout_stream=180
# net.ipv6.conf.all.forwarding=1
+
+# disable bridge firewalling by default
+net.bridge.bridge-nf-call-arptables=0
+net.bridge.bridge-nf-call-ip6tables=0
+net.bridge.bridge-nf-call-iptables=0