aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 18 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index c4f168d..c7fe645 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,23 +7,11 @@
#
#
#
-man1_MANS=nrfdfu.man
-
-INCLUDES= ${BLUEZ_CFLAGS} ${JSON_C_CFLAGS} ${LIBZIP_CFLAGS}
-
-noinst_HEADERS= prototypes.h ${CHDRS} ${BLUEZ_HDRS}
+AUTOMAKE_OPTIONS = subdir-objects
+man1_MANS=nrfdfu.man
bin_PROGRAMS = nrfdfu
-nrfdfu_SOURCES = ${SRCS}
-nrfdfu_LDADD = ${BLUEZ_LIBS} ${JSON_C_LIBS} ${LIBZIP_LIBS}
-
-tidy: ${CSRCS} ${CHDRS}
- indent -i2 -ts0 ${CSRCS} ${CHDRS}
- /bin/rm -f *~
-
-AM_CFLAGS=-g -Wall
-
CSRCS= \
nrfdfu.c \
@@ -38,7 +26,7 @@ CHDRS= \
ble.h \
dfu.h \
manifest.h \
- project.h \
+ project.h
BLUEZ_SRCS= \
bluez/att.c \
@@ -67,6 +55,21 @@ BLUEZ_HDRS= \
bluez/util.h \
bluez/uuid.h
+
+AM_CPPFLAGS = ${BLUEZ_CFLAGS} ${JSON_C_CFLAGS} ${LIBZIP_CFLAGS}
+
+noinst_HEADERS= prototypes.h ${CHDRS} ${BLUEZ_HDRS}
+
+
+nrfdfu_SOURCES = ${CSRCS} ${BLUEZ_SRCS}
+nrfdfu_LDADD = ${BLUEZ_LIBS} ${JSON_C_LIBS} ${LIBZIP_LIBS}
+
+tidy: ${CSRCS} ${CHDRS}
+ indent -i2 -ts0 ${CSRCS} ${CHDRS}
+ /bin/rm -f *~
+
+AM_CFLAGS=-g -Wall
+
protos:
echo > prototypes.h
${CPROTO} ${CPPFLAGS} -e -v ${CSRCS} > prototypes.new