aboutsummaryrefslogtreecommitdiffstats
path: root/plpftp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plpftp/Makefile.am')
-rw-r--r--plpftp/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/plpftp/Makefile.am b/plpftp/Makefile.am
index 4ca89a0..4805577 100644
--- a/plpftp/Makefile.am
+++ b/plpftp/Makefile.am
@@ -2,12 +2,16 @@
#
INCLUDES=-I$(top_srcdir)/lib
-#if HAVE_LIBREADLINE
+if HAVE_LIBREADLINE
+if ADD_LIBCURSES
+LIBREADLINE=-lreadline -lcurses
+else
LIBREADLINE=-lreadline
-#endif
-#if HAVE_LIBHISTORY
+endif
+endif
+if HAVE_LIBHISTORY
LIBHISTORY=-lhistory
-#endif
+endif
bin_PROGRAMS = plpftp
plpftp_LDADD = $(top_srcdir)/lib/libplp.la $(LIBREADLINE) $(LIBHISTORY)