aboutsummaryrefslogtreecommitdiffstats
path: root/kde2/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kde2/plugins/Makefile.am')
-rw-r--r--kde2/plugins/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/kde2/plugins/Makefile.am b/kde2/plugins/Makefile.am
index e0cfb82..ab12d54 100644
--- a/kde2/plugins/Makefile.am
+++ b/kde2/plugins/Makefile.am
@@ -1,17 +1,16 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/lib
-LDFLAGS = $(all_libraries)
kdemoduledir = $(kde_moduledir)
kdemodule_LTLIBRARIES = libplpprops.la
-libplpprops_la_LDFLAGS = $(LIBDEBUG) $(all_libraries) $(KDE_PLUGIN)
-
METASOURCES = AUTO
libplpprops_la_SOURCES = plpprops.cc plppropsFactory.cc pie3dpiece.cpp \
pie3dwidget.cpp
-libplpprops_la_LIBADD = -L$(top_srcdir)/lib/.libs $(top_srcdir)/lib/libplp.la $(LIB_KIO) $(LIB_KFILE)
+libplpprops_la_LIBADD = $(LIB_PLP) $(LIB_KIO) $(LIB_KFILE)
+libplpprops_la_LDFLAGS = $(PLP_LDFLAGS) $(KDE_LDFLAGS) $(LIBDEBUG) $(KDE_PLUGIN)
+
noinst_HEADERS = plpprops.h plppropsFactory.h pie3dpiece.h pie3dwidget.h
services_DATA = plpprops.desktop