aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 9 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d84b9e..72ccadc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,32 +1,18 @@
# $Id$
#
-SUBDIRS = intl po lib ncpd plpnfsd plpfuse plpftp plpprint sisinstall doc .
+ACLOCAL_AMFLAGS = -I m4
+
+SUBDIRS = intl po lib ncpd plpnfsd plpfuse plpftp plpprint sisinstall doc
-EXTRA_DIST = CHANGES COPYING README TODO HISTORY INSTALL ABOUT-NLS include/*.h* \
+EXTRA_DIST = AUTHORS COPYING INSTALL NEWS README TODO HISTORY ABOUT-NLS include/*.h* \
etc/*magic etc/*.in etc/*.c etc/psidump* etc/udev-usbserial-plptools.rules \
- conf/m4/plptools/*.m4 conf/[a-l]* conf/missing conf/mkinstalldirs \
- debian/*
-DISTCLEANFILES = etc/psion etc/psion.SuSE
+ etc/plptools.spec
-TMPDEST=
+DISTCLEANFILES = etc/psion etc/psion.SuSE
install-data-local:
- test "$(initdir)" != "none" && \
- install -m 755 etc/psion $(DESTDIR)$(initdir)/psion || :
+ install -m 755 etc/psion $(DESTDIR)$(initdir)/psion
-dist-hook:
- $(MAKE) TMPDEST=$(distdir)/ kdoc specfile
- test -f CVS/Root && cvs2cl -W 1800 -S --no-wrap --prune \
- --gmt -f $(distdir)/ChangeLog || \
- cp -f ChangeLog $(distdir)/ChangeLog
- rm -rf $(distdir)/debian/CVS
-
-kdoc:
- kdoc -d $(TMPDEST)doc/api -n libplp --strip-h-path $(TMPDEST)lib/*.h
-
-specfile:
- sed -e "s/\@VERSION\@/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
- > $(TMPDEST)etc/plptools.spec
-
-ACLOCAL_AMFLAGS = -I m4
+dist-local:
+ kdoc -d doc/api -n libplp --strip-h-path lib/*.h