aboutsummaryrefslogtreecommitdiffstats
path: root/ncpd/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-03-05 17:58:11 +0000
committerFritz Elfert <felfert@to.com>2002-03-05 17:58:11 +0000
commitcb2577b29fe7b93e9b168ded7f35da748fdeaf1d (patch)
treed7cf962ead89069f885f8da7137feb94acb3dfec /ncpd/Makefile.am
parent8f9ae0a93ba3ea860a28933c2a411eae9365c859 (diff)
downloadplptools-cb2577b29fe7b93e9b168ded7f35da748fdeaf1d.tar.gz
plptools-cb2577b29fe7b93e9b168ded7f35da748fdeaf1d.tar.bz2
plptools-cb2577b29fe7b93e9b168ded7f35da748fdeaf1d.zip
- Re-Implemented lower levels of ncpd (packet and link).
ncpd is now multithreaded. Results in much better performance and less CPU usage.
Diffstat (limited to 'ncpd/Makefile.am')
-rw-r--r--ncpd/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/ncpd/Makefile.am b/ncpd/Makefile.am
index 1ead85c..ca715b2 100644
--- a/ncpd/Makefile.am
+++ b/ncpd/Makefile.am
@@ -1,10 +1,12 @@
# $Id$
#
INCLUDES=-I$(top_srcdir)/lib
+CFLAGS += -D_REENTRANT
+CXXFLAGS += -D_REENTRANT
sbin_PROGRAMS = ncpd
-ncpd_LDADD = $(top_srcdir)/lib/libplp.la $(LIBCCMALLOC_CXX)
+ncpd_LDADD = $(top_srcdir)/lib/libplp.la -lpthread $(LIBCCMALLOC_CXX)
ncpd_SOURCES = channel.cc link.cc linkchan.cc main.cc \
ncp.cc packet.cc socketchan.cc mp_serial.c
EXTRA_DIST = channel.h link.h linkchan.h mp_serial.h ncp.h packet.h socketchan.h