aboutsummaryrefslogtreecommitdiffstats
path: root/kde2/plugins/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
committerFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
commitadec25f54995debcaa165864eaaf4654802f0ca0 (patch)
tree6c60f3f3939ab61af128208ee85eb80bb1ef7ce4 /kde2/plugins/Makefile.am
parenteb1cae45049c5b46caf4eba36f67997d921b018b (diff)
downloadplptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.gz
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.bz2
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.zip
- Debian package now nearly finished
- Applied patches from Chris Halls <chris.halls@gmx.de>
Diffstat (limited to 'kde2/plugins/Makefile.am')
-rw-r--r--kde2/plugins/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/kde2/plugins/Makefile.am b/kde2/plugins/Makefile.am
index f8e20f7..e0cfb82 100644
--- a/kde2/plugins/Makefile.am
+++ b/kde2/plugins/Makefile.am
@@ -1,14 +1,13 @@
-libdir=$(kde_libraries)
-
INCLUDES = $(all_includes) -I$(top_srcdir)/lib
LDFLAGS = $(all_libraries)
-libplpprops_la_LDFLAGS = $(LIBDEBUG) $(all_libraries) -module -no-undefined -version-info $(LIBVERSION)
+kdemoduledir = $(kde_moduledir)
+kdemodule_LTLIBRARIES = libplpprops.la
-METASOURCES = AUTO
+libplpprops_la_LDFLAGS = $(LIBDEBUG) $(all_libraries) $(KDE_PLUGIN)
-lib_LTLIBRARIES = libplpprops.la
+METASOURCES = AUTO
libplpprops_la_SOURCES = plpprops.cc plppropsFactory.cc pie3dpiece.cpp \
pie3dwidget.cpp
@@ -17,7 +16,7 @@ noinst_HEADERS = plpprops.h plppropsFactory.h pie3dpiece.h pie3dwidget.h
services_DATA = plpprops.desktop
servicesdir = $(kde_servicesdir)
-EXTRA_DIST += $(services_DATA)
+EXTRA_DIST = $(services_DATA)
messages:
$(XGETTEXT) -C -ki18n -kI18N_NOOP -ktranslate -kaliasLocale *.cc *.cpp *.h && mv messages.po ../po/libplpprops.pot