aboutsummaryrefslogtreecommitdiffstats
path: root/kde2/plugins/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2001-02-06 01:01:46 +0000
committerFritz Elfert <felfert@to.com>2001-02-06 01:01:46 +0000
commita9fe8f28a4a9aaf1d9b84dbc6907849ace87f66e (patch)
tree0dd290cdf04cfd17a4ab4d0eb86bcb48137a02cb /kde2/plugins/Makefile.am
parenta8787d39b2bf1851cdea64a5e0eccc2aff7f15de (diff)
downloadplptools-a9fe8f28a4a9aaf1d9b84dbc6907849ace87f66e.tar.gz
plptools-a9fe8f28a4a9aaf1d9b84dbc6907849ace87f66e.tar.bz2
plptools-a9fe8f28a4a9aaf1d9b84dbc6907849ace87f66e.zip
- Added KDE2 PropsDialog Plugin (incomplete)
- Fixed some KDE related autoconf stuff - Added PlpDrive class for returning results from rfsv:devinfo - Added auto-watch in ppsocket and finally got rid of the nasty SIGPIPE bug. Now it's no more necessary to ignore SIGPIPE in applications. - Made constructors of rfsv16, rfsv32, rpcs16 and rpcs32 private to enforce use of the factories. - Removed error output in the factories and replaced that by error codes which can be retrieved and evaluated by an application.
Diffstat (limited to 'kde2/plugins/Makefile.am')
-rw-r--r--kde2/plugins/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde2/plugins/Makefile.am b/kde2/plugins/Makefile.am
new file mode 100644
index 0000000..9ef736d
--- /dev/null
+++ b/kde2/plugins/Makefile.am
@@ -0,0 +1,26 @@
+
+AM_CPPFLAGS = -DQT_NO_CAST_ASCII
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/lib
+LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+libplpprops_la_LDFLAGS = $(LIBDEBUG) $(all_libraries) -module -no-undefined -version-info $(LIBVERSION)
+
+METASOURCES = AUTO
+
+lib_LTLIBRARIES = libplpprops.la
+
+libplpprops_la_SOURCES = plpprops.cc plppropsFactory.cc pie3dpiece.cpp \
+ pie3dwidget.cpp
+libplpprops_la_LIBADD = -L$(top_srcdir)/lib -lplp $(LIB_KIO) $(LIB_KFILE)
+noinst_HEADERS = plpprops.h plppropsFactory.h pie3dpiece.h pie3dwidget.h
+
+services_DATA = plpprops.desktop
+servicesdir = $(kde_servicesdir)
+
+#
+# remove all intermediate files that can be recreated using
+# Makefile.cvs
+#
+maintainer-clean-local:
+ rm -f Makefile.in *.closure