aboutsummaryrefslogtreecommitdiffstats
path: root/kde2/kioslave/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
committerFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
commitadec25f54995debcaa165864eaaf4654802f0ca0 (patch)
tree6c60f3f3939ab61af128208ee85eb80bb1ef7ce4 /kde2/kioslave/Makefile.am
parenteb1cae45049c5b46caf4eba36f67997d921b018b (diff)
downloadplptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.gz
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.bz2
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.zip
- Debian package now nearly finished
- Applied patches from Chris Halls <chris.halls@gmx.de>
Diffstat (limited to 'kde2/kioslave/Makefile.am')
-rw-r--r--kde2/kioslave/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/kde2/kioslave/Makefile.am b/kde2/kioslave/Makefile.am
index f0efa3a..f306934 100644
--- a/kde2/kioslave/Makefile.am
+++ b/kde2/kioslave/Makefile.am
@@ -1,19 +1,19 @@
# $Id$
-libdir=$(kde_libraries)
-
maintainer-clean-local:
rm -f Makefile.in
INCLUDES = $(all_includes) -I$(top_srcdir)/lib
LDFLAGS = $(all_libraries) $(KDE_RPATH)
-kio_plp_la_LDFLAGS = -module -avoid-version
+kdemoduledir = $(kde_moduledir)
+kdemodule_LTLIBRARIES = kio_plp.la
-lib_LTLIBRARIES = kio_plp.la
+kio_plp_la_LDFLAGS = -module $(KDE_PLUGIN)
kio_plp_la_SOURCES = kio_plp.cpp
-kio_plp_la_LIBADD = -L$(top_srcdir)/lib/.libs $(top_srcdir)/lib/libplp.la $(LIB_KIO)
+kio_plp_la_LIBADD = -L$(top_srcdir)/lib/.libs $(top_srcdir)/lib/libplp.la \
+ $(LIB_KIO)
noinst_HEADERS = kio_plp.h