aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-07-17 10:55:12 +0000
committerFritz Elfert <felfert@to.com>2002-07-17 10:55:12 +0000
commit8f001952e6508747d6354da8f647e90d3574caa6 (patch)
treef4f186158598efbed042affdba39a4133f3dc17e /debian/rules
parent7c3fcf9330122c960e2abee7412e634cf0dae4de (diff)
downloadplptools-8f001952e6508747d6354da8f647e90d3574caa6.tar.gz
plptools-8f001952e6508747d6354da8f647e90d3574caa6.tar.bz2
plptools-8f001952e6508747d6354da8f647e90d3574caa6.zip
- Applied suggestions from autotools-dev/README.Debian.gz
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 12 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 644f289..b210a6c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,16 @@ export DH_VERBOSE=1
# This is the debhelper compatability version to use.
export DH_COMPAT=3
+# Set config options
+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
tmp = $(shell pwd)/debian/tmp
ltmp = $(tmp)/usr/share/lintian/overrides
hdir = $(shell kde-config --expandvars -install html)
@@ -19,17 +29,8 @@ hdir = $(shell kde-config --expandvars -install html)
configure: configure-stamp
configure-stamp:
dh_testdir
- # Add here commands to configure the package.
- aclocal -I conf/m4/plptools -I conf/m4/kde
- echo n | gettextize -f
- -test -f po/ChangeLog~ && mv -f po/ChangeLog~ po/ChangeLog
- libtoolize --force
- autoheader
- automake --add-missing
- make -C kde2 -f Makefile.am am_edit
- autoconf
- touch include/stamp-h.in
- ./configure --prefix=/usr --with-mountdir=/var/lib/plptools/mnt \
+ ./configure $(confflags) --prefix=/usr \
+ --with-mountdir=/var/lib/plptools/mnt \
--mandir=/usr/share/man --with-initdir=none --enable-kde \
--disable-rpath
touch configure-stamp