aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-07-14 02:54:13 +0000
committerFritz Elfert <felfert@to.com>2002-07-14 02:54:13 +0000
commit000a4885669921b160ba31328fb43842fcd3c6e1 (patch)
treeb3e32ca0ca37c5d3feff0a4edfa785b2d2f9cf39 /debian/rules
parent94469aaba04a168f95a42df27476e1c3a98f0799 (diff)
downloadplptools-000a4885669921b160ba31328fb43842fcd3c6e1.tar.gz
plptools-000a4885669921b160ba31328fb43842fcd3c6e1.tar.bz2
plptools-000a4885669921b160ba31328fb43842fcd3c6e1.zip
- Debian packaging based on John's package of plptools-0.10
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules91
1 files changed, 91 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ed8b8b5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,91 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=3
+
+tmp = $(shell pwd)/debian/tmp
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ aclocal -I conf/m4/plptools -I conf/m4/kde
+ echo n | gettextize -f
+ -test -f po/ChangeLog~ && mv -f po/ChangeLog~ po/ChangeLog
+ libtoolize --force
+ autoheader
+ automake --add-missing
+ make -C kde2 -f Makefile.am am_edit
+ autoconf
+ touch include/stamp-h.in
+ ./configure --prefix=/usr --with-mountdir=/var/lib/plptools/mnt \
+ --with-initdir=none --enable-kde
+ touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+ dh_testdir
+ # Add here commands to compile the package.
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ # Add here commands to clean up after the build process.
+ -$(MAKE) maintainer-clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ $(MAKE) DESTDIR=$(tmp) install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# dh_testversion
+ dh_testdir
+ dh_testroot
+ dh_installdebconf -a
+ dh_installdocs -a
+# dh_installexamples
+ dh_installmenu -a
+# dh_installemacsen
+# dh_installpam
+ dh_installinit -a
+# dh_installcron
+ dh_installman -a
+# dh_installinfo
+# dh_undocumented
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ # You may want to make some executables suid here.
+# dh_suidregister
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install