aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2000-11-11 14:39:35 +0000
committerFritz Elfert <felfert@to.com>2000-11-11 14:39:35 +0000
commit67b6274d0f8fa796770ebb5201dbfaf2b7c1dd6d (patch)
tree58f7380a6246c0bfbc89975f311ad46d4e2d16a1 /configure.in
parent6302b9778db245516f808cb18d5fcc9d9b4bdf86 (diff)
downloadplptools-67b6274d0f8fa796770ebb5201dbfaf2b7c1dd6d.tar.gz
plptools-67b6274d0f8fa796770ebb5201dbfaf2b7c1dd6d.tar.bz2
plptools-67b6274d0f8fa796770ebb5201dbfaf2b7c1dd6d.zip
Added checks for broken libreadline-4 on RH7 (needs libcurses instead of
automatically using libtermcap which does export _NO_ symbols on RH7!!!) Added --disable-readline and --disable-history Fixed a function prototype
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 31 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 3b8a96c..e73ecd3 100644
--- a/configure.in
+++ b/configure.in
@@ -49,18 +49,37 @@ AC_SUBST(EXTRA_OBJS)
dnl checks for libraries
dnl readline and history for plpftp
-AC_CHECK_LIB(readline, readline,
-[
- AC_DEFINE_UNQUOTED(HAVE_LIBREADLINE)
- have_libreadline=true
-])
-AC_CHECK_LIB(history, add_history,
-[
- AC_DEFINE_UNQUOTED(HAVE_LIBHISTORY)
- have_libhistory=true
-])
-AM_CONDITIONAL(HAVE_LIBREADLINE, test x$have_libreadline = xtrue)
-AM_CONDITIONAL(HAVE_LIBHISTORY, test x$have_libhistory = xtrue)
+ac_enable_readline=yes
+AM_CONDITIONAL(HAVE_LIBREADLINE, false)
+AM_CONDITIONAL(ADD_LIBCURSES, false)
+AC_ARG_ENABLE(readline,
+ [ --disable-readline disable libreadline support [no]],
+ if test "$enableval" = "no" ; then
+ AC_MSG_RESULT([support for libreadline disabled])
+ ac_enable_readline=no
+ fi
+)
+if test "x$ac_enable_readline" = "xyes" ; then
+ AC_CHECK_READLINE
+fi
+
+ac_enable_history=yes
+AM_CONDITIONAL(HAVE_LIBHISTORY, false)
+AC_ARG_ENABLE(history,
+ [ --disable-history disable libhistory support [no]],
+ if test "$enableval" = "no" ; then
+ AC_MSG_RESULT([support for libhistory disabled])
+ ac_enable_history=no
+ fi
+)
+if test "x$ac_enable_history" = "xyes" ; then
+ AC_CHECK_LIB(history, add_history,
+ [
+ AC_DEFINE_UNQUOTED(HAVE_LIBHISTORY)
+ have_libhistory=true
+ ])
+ AM_CONDITIONAL(HAVE_LIBHISTORY, test x$have_libhistory = xtrue)
+fi
dnl these three are for solaris
AC_CHECK_LIB(socket, socket)