aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2000-10-09 14:45:10 +0000
committerFritz Elfert <felfert@to.com>2000-10-09 14:45:10 +0000
commit64535f8c1600f3501bec9aab107199a2c1293df6 (patch)
treefb4be8095dd6742762bab320a36c0fe1ab415f0c /configure.in
parent088423c49e616c16f55bae5453b46cf810648afc (diff)
downloadplptools-64535f8c1600f3501bec9aab107199a2c1293df6.tar.gz
plptools-64535f8c1600f3501bec9aab107199a2c1293df6.tar.bz2
plptools-64535f8c1600f3501bec9aab107199a2c1293df6.zip
Misc. small fixes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a7e2ca6..3b8a96c 100644
--- a/configure.in
+++ b/configure.in
@@ -16,10 +16,24 @@ AC_CHECK_COMPILERS
AC_PROG_AWK
AC_PATH_PROG(SED,sed)
-CFLAGS="-O"
-test "$GCC" = yes && CFLAGS="-O2 -Wall"
-AC_PATH_PROG(CC_PATH, $CC)
-test "$CC_PATH" = /opt/SUNWspro/bin/cc && CFLAGS="-xO2 -v"
+dnl This is stupid for two resaons:
+dnl
+dnl 1. It doesn't save and restore CFLAGS if it's _not_ Sun's cc
+dnl (these have been set already in AC_CHECK_COMPILERS
+dnl 2. It assumes cc installed at a fixed path which may not be true
+dnl pkgadd -r can install anywhere.
+dnl
+dnl A correct version should check by using cc's _behavior_, not path
+dnl and save and restore CFLAGS, if it's not Sun's cc.
+dnl
+dnl -> Commented out for now because i have gcc on Solaris, no Sun cc.
+dnl If somebody complains, (s)he should send me some cc output and i
+dnl can add a correct check to AC_CHECK_COMPILERS (where it belongs).
+dnl -Fritz
+dnl
+dnl test "$GCC" = yes && CFLAGS="-O2 -Wall"
+dnl AC_PATH_PROG(CC_PATH, $CC)
+dnl test "$CC_PATH" = /opt/SUNWspro/bin/cc && CFLAGS="-xO2 -v"
dnl checking for aix
AC_MSG_CHECKING(for AIX)