aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-02-28 20:59:11 +0000
committerFritz Elfert <felfert@to.com>2002-02-28 20:59:11 +0000
commit4f497127917554c3a7249658feee9f5bbae84b88 (patch)
tree99e50676b2ee4a410fd9300693a825a0201b6c5e /configure.in
parenteecba3b5fcb47a01e6e13ee1940def989f6dd22d (diff)
downloadplptools-4f497127917554c3a7249658feee9f5bbae84b88.tar.gz
plptools-4f497127917554c3a7249658feee9f5bbae84b88.tar.bz2
plptools-4f497127917554c3a7249658feee9f5bbae84b88.zip
- Added SIS stuff by Daniel Brahneborg
- Change readline detection again
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ecf62d4..c8f2ed3 100644
--- a/configure.in
+++ b/configure.in
@@ -77,7 +77,7 @@ if test "x$ac_enable_readline" = "xyes" ; then
fi
ac_enable_history=yes
-AM_CONDITIONAL(HAVE_LIBHISTORY, false)
+ac_cv_libhistory=
AC_ARG_ENABLE(history,
[ --disable-history disable libhistory support [no]],
if test "$enableval" = "no" ; then
@@ -89,10 +89,11 @@ if test "x$ac_enable_history" = "xyes" ; then
AC_CHECK_LIB(history, add_history,
[
AC_DEFINE_UNQUOTED(HAVE_LIBHISTORY)
- have_libhistory=true
+ ac_cv_libhistory=-lhistory
])
- AM_CONDITIONAL(HAVE_LIBHISTORY, test x$have_libhistory = xtrue)
fi
+LIBHISTORY=${ac_cv_libhistory}
+AC_SUBST(LIBHISTORY)
dnl these three are for solaris
AC_CHECK_LIB(socket, socket)
@@ -278,6 +279,7 @@ AC_OUTPUT(
kde2/doc/de/Makefile
plpbackup/Makefile
plpprint/Makefile
+ sisinstall/Makefile
doc/Makefile
doc/api/Makefile
include/config.h