aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2008-01-29 21:25:40 +0000
committerReuben Thomas <rrt@sc3d.org>2008-01-29 21:25:40 +0000
commitdeb29cbd1004f2eb8c994e9bd7fe3e375a46272e (patch)
tree3116b75f3e73af7e739cd647e6c57912f06806ae /configure.ac
parent48d9fff0cd1268d8cbf5838a4acbb2452dc7783b (diff)
downloadplptools-deb29cbd1004f2eb8c994e9bd7fe3e375a46272e.tar.gz
plptools-deb29cbd1004f2eb8c994e9bd7fe3e375a46272e.tar.bz2
plptools-deb29cbd1004f2eb8c994e9bd7fe3e375a46272e.zip
Add support for libattr.
Add extra warnings to C compilation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85de1bf..7b6f5e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,11 @@ fi
AC_MSG_RESULT(no)
])
+dnl Turn on additional compiler warnings
+if test "$GCC" = "yes"; then
+ CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wstrict-prototypes -pedantic"
+fi
+
dnl NLS support
ALL_LINGUAS="de sv"
AM_GNU_GETTEXT
@@ -128,7 +133,7 @@ AC_RUN_IFELSE([
# check for libattr for plpfuse
AC_CHECK_HEADER(attr/attributes.h,,
[AC_MSG_ERROR([Need libattr to build plpfuse])])
-AC_CHECK_LIB(attr,attr_set,,
+AC_CHECK_LIB(attr, attr_set,,
[AC_MSG_ERROR([Need libattr to build plpfuse])])
dnl these three are for solaris