aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2008-01-30 01:05:07 +0000
committerReuben Thomas <rrt@sc3d.org>2008-01-30 01:05:07 +0000
commitab62a3096711e3e9c87b6c0405fcecf81f753d53 (patch)
tree76a6c4878b8b44d869703f4335af9f29a896f1ed /configure.ac
parentf905e7c9aa34e0364f6b8b58715495257b9600c2 (diff)
downloadplptools-ab62a3096711e3e9c87b6c0405fcecf81f753d53.tar.gz
plptools-ab62a3096711e3e9c87b6c0405fcecf81f753d53.tar.bz2
plptools-ab62a3096711e3e9c87b6c0405fcecf81f753d53.zip
Stop libattr and libfuse being linked against by programs other than
plpfuse. Fix logic of plp_setxattr. It doesn't need to read the non-x attributes, and it now treats the set and cleared EPOC attribute bits properly (I hope!).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7b6f5e7..5cda2ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,7 +109,7 @@ AC_SUBST(LIBHISTORY)
# FUSE for plpfuse
AC_CHECK_HEADER(fuse.h,,
[AC_MSG_ERROR([Need fuse.h to build plpfuse])])
-AC_CHECK_LIB(fuse,fuse_new,,
+AC_CHECK_LIB(fuse,fuse_new, [true],
[AC_MSG_ERROR([Need libfuse to build plpfuse])])
# check for a supported version of FUSE
@@ -133,7 +133,7 @@ AC_RUN_IFELSE([
# check for libattr for plpfuse
AC_CHECK_HEADER(attr/attributes.h,,
[AC_MSG_ERROR([Need libattr to build plpfuse])])
-AC_CHECK_LIB(attr, attr_set,,
+AC_CHECK_LIB(attr, attr_set, [true],
[AC_MSG_ERROR([Need libattr to build plpfuse])])
dnl these three are for solaris