aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2007-12-10 00:53:26 +0000
committerReuben Thomas <rrt@sc3d.org>2007-12-10 00:53:26 +0000
commit9727d8815fcfe4ad249dec03f625dd86f9109979 (patch)
tree1b1aed70b0be9b61da697d6cf5bcdfed6c9c9d60 /configure.ac
parenta15ad3d69bdb69fde109be0c41e86a4402e477fa (diff)
downloadplptools-9727d8815fcfe4ad249dec03f625dd86f9109979.tar.gz
plptools-9727d8815fcfe4ad249dec03f625dd86f9109979.tar.bz2
plptools-9727d8815fcfe4ad249dec03f625dd86f9109979.zip
Massively simplify Makefile.am.
Take configure.ac out of MAINTAINER_MODE so stuff works better (e.g. Makefile depends on Makefile.am). Remove cvs2cl. Remove po/Makefile.in, which seems to be in by mistake.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index fb401cc..eb2cebb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_REVISION($Revision$)dnl revision of this configure.in script
+AC_INIT(plptools, 0.19, plptools-developers@lists.sourceforge.net)
+AC_CANONICAL_SYSTEM
+AM_INIT_AUTOMAKE
-AC_INIT(Makefile.am)
+dnl Basic settings
AC_GNU_SOURCE
-AC_CANONICAL_SYSTEM
AM_CONFIG_HEADER(include/config.h)
-AM_INIT_AUTOMAKE(plptools, 0.19)
AM_PROG_LIBTOOL
dnl Set library version
@@ -13,9 +13,6 @@ min=$(echo ${VERSION} | cut -d. -f2)
LIBVERSION=${maj}:${min}:${maj}
AC_SUBST(LIBVERSION)
-dnl Enable Maintainer stuff
-AM_MAINTAINER_MODE
-
dnl checks for programs
AM_PROG_CC_C_O
AC_PROG_MAKE_SET
@@ -289,7 +286,7 @@ AH_BOTTOM([
])
-AC_OUTPUT(
+AC_CONFIG_FILES(
Makefile
intl/Makefile
po/Makefile.in
@@ -311,3 +308,4 @@ AC_OUTPUT(
doc/sisinstall.man
doc/plpprintd.man
)
+AC_OUTPUT