aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2008-03-22 13:14:27 +0000
committerReuben Thomas <rrt@sc3d.org>2008-03-22 13:14:27 +0000
commit69bd0638b064dc73571d5d00cb2313c4d046c163 (patch)
tree7d693527a842144a79161c15c33eb37687659c9c /configure.ac
parent22cfe29c0b6d9c861b5c4b397b8edff8de394a75 (diff)
downloadplptools-69bd0638b064dc73571d5d00cb2313c4d046c163.tar.gz
plptools-69bd0638b064dc73571d5d00cb2313c4d046c163.tar.bz2
plptools-69bd0638b064dc73571d5d00cb2313c4d046c163.zip
Don't try to build plpfuse if we lack libattr or FUSE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 42757cf..89b0f4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT(plptools, 1.0.0, plptools-developers@lists.sourceforge.net)
+AC_INIT(plptools, 1.0.1, plptools-developers@lists.sourceforge.net)
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE
@@ -107,10 +107,8 @@ LIBHISTORY=${ac_cv_libhistory}
AC_SUBST(LIBHISTORY)
# FUSE for plpfuse
-AC_CHECK_HEADER(fuse.h,,
- [AC_MSG_ERROR([Need fuse.h to build plpfuse])])
-AC_CHECK_LIB(fuse,fuse_new, [true],
- [AC_MSG_ERROR([Need libfuse to build plpfuse])])
+AC_CHECK_HEADER(fuse.h,, enable_fuse=no)
+AC_CHECK_LIB(fuse,fuse_new, [true], enable_fuse=no)
# check for a supported version of FUSE
AC_MSG_CHECKING([for supported FUSE API version])
@@ -126,17 +124,17 @@ AC_RUN_IFELSE([
]])],
[AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])
- AC_MSG_FAILURE([plpfuse requires FUSE 2.6 or newer.])
+ enable_fuse=no
]
)
# check for libattr for plpfuse
-AC_CHECK_HEADER(attr/attributes.h,,
- [AC_MSG_ERROR([Need libattr to build plpfuse])])
-AC_CHECK_LIB(attr, attr_set, [true],
- [AC_MSG_ERROR([Need libattr to build plpfuse])])
+AC_CHECK_HEADER(attr/attributes.h,, enable_fuse=no)
+AC_CHECK_LIB(attr, attr_set, [true], enable_fuse=no)
-dnl these three are for solaris
+AM_CONDITIONAL(BUILD_PLPFUSE, test x$enable_plpfuse = xyes)
+
+dnl these three are for Solaris
AC_CHECK_LIB(socket, socket)
AC_CHECK_LIB(nsl, gethostbyname)
ac_save_LDFLAGS=$LDFLAGS; LDFLAGS="-L/usr/ucblib -R/usr/ucblib $LDFLAGS"