aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2001-07-23 19:40:03 +0000
committerFritz Elfert <felfert@to.com>2001-07-23 19:40:03 +0000
commitf71ff766639368ae50b89858dee11bf2ff3f0061 (patch)
treeef5249366e78f0d828b0b20f1a80deffce5addd6 /Makefile.am
parent9d9530a14c61568ecbdb4addb80195646f4e0a7b (diff)
downloadplptools-f71ff766639368ae50b89858dee11bf2ff3f0061.tar.gz
plptools-f71ff766639368ae50b89858dee11bf2ff3f0061.tar.bz2
plptools-f71ff766639368ae50b89858dee11bf2ff3f0061.zip
Added SuSE-related install-stuff
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e3fb06..5775bc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,28 @@ maintainer-clean-local:
find . -name "\.\#*" -exec rm -f {} \;
sh conf/intlclean
+# Suse doesn't have chkconfig, so we need to create the symlinks here.
+install-data-local:
+ if [ -f /etc/SuSE-release ] ; then \
+ install -m 755 etc/psion.SuSE $(DESTDIR)/etc/rc.d/init.d/psion ;\
+ ln -s ../psion /etc/rc.d/rc2.d/S45psion ;\
+ ln -s ../psion /etc/rc.d/rc3.d/S45psion ;\
+ ln -s ../psion /etc/rc.d/rc4.d/S45psion ;\
+ ln -s ../psion /etc/rc.d/rc5.d/S45psion ;\
+ ln -s ../psion /etc/rc.d/rc1.d/K70psion ;\
+ ln -s ../psion /etc/rc.d/rc0.d/K70psion ;\
+ ln -s ../psion /etc/rc.d/rc6.d/K70psion ;\
+ grep -v START_PSION /etc/rc.config > /etc/rc.config.psion ;\
+ ( \
+ echo '# Set START_PSION to yes to start Psion support' ;\
+ echo 'START_PSION=yes' ;\
+ ) >> /etc/rc.config.psion ;\
+ cp /etc/rc.config /etc/rc.config.old ;\
+ mv /etc/rc.config.psion /etc/rc.config ;\
+ else \
+ install -m 755 etc/psion $(DESTDIR)/etc/rc.d/init.d/psion ;\
+ fi
+
dist-hook:
$(MAKE) TMPDEST=$(distdir)/ kdoc specfile
$(MAKE) -C $(distdir)/kde2 -f Makefile.am am_edit