aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
committerFritz Elfert <felfert@to.com>2002-07-16 05:58:13 +0000
commitadec25f54995debcaa165864eaaf4654802f0ca0 (patch)
tree6c60f3f3939ab61af128208ee85eb80bb1ef7ce4 /Makefile.am
parenteb1cae45049c5b46caf4eba36f67997d921b018b (diff)
downloadplptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.gz
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.tar.bz2
plptools-adec25f54995debcaa165864eaaf4654802f0ca0.zip
- Debian package now nearly finished
- Applied patches from Chris Halls <chris.halls@gmx.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fc6c75..243dc1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,14 +9,16 @@ endif
SUBDIRS = intl po lib ncpd plpnfsd plpftp plpbackup plpprint sisinstall \
$(KDESUB) doc .
+
EXTRA_DIST = CHANGES COPYING README TODO INSTALL ABOUT-NLS include/*.h* \
- etc/*magic etc/*.in etc/*.c etc/psidump* patches conf/m4/kde/*.m4 \
+ etc/*magic etc/*.in etc/*.c etc/psidump* conf/m4/kde/*.m4 \
conf/m4/plptools/*.m4 conf/[a-l]* conf/missing conf/mkinstalldirs \
- debian
+ debian/* patches/*
DISTCLEANFILES = etc/psion etc/psion.SuSE etc/psion.SuSE8
AUTOMAKE_OPTIONS = foreign
TMPDEST=
+
#
# remove all intermediate files that can be recreated using
# Makefile.cvs
@@ -40,10 +42,12 @@ dist-hook:
test -f CVS/Root && conf/cvs2cl -W 1800 -S --no-wrap --prune \
--gmt -f $(distdir)/ChangeLog || \
cp -f ChangeLog $(distdir)/ChangeLog
+ # remove CVS from debian/ and patches/ subdirs
+ rm -rf $(distdir)/debian/CVS $(distdir)/patches/CVS
kdoc:
kdoc -d $(TMPDEST)doc/api -n libplp --strip-h-path $(TMPDEST)lib/*.h
specfile:
- sed -e "s/_VERSION_/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
+ sed -e "s/\@VERSION\@/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
> $(TMPDEST)etc/plptools.spec