aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2007-12-15 14:17:00 +0000
committerReuben Thomas <rrt@sc3d.org>2007-12-15 14:17:00 +0000
commita9f3b404def8eb39a643db542d70572da042e9e3 (patch)
tree244480bc607d729c1b8ce6fadbabf625d543bd46 /Makefile.am
parent07afd554fe68dbc1ba470ad75830276ad3560a5d (diff)
downloadplptools-a9f3b404def8eb39a643db542d70572da042e9e3.tar.gz
plptools-a9f3b404def8eb39a643db542d70572da042e9e3.tar.bz2
plptools-a9f3b404def8eb39a643db542d70572da042e9e3.zip
Add plpfuse.h to headers.
Add "release" target to Makefile.am. Updates to .po files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 362b489..9178eda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,3 +13,24 @@ install-data-local:
dist-local:
kdoc -d doc/api -n libplp --strip-h-path lib/*.h
+
+NOTES = release-notes
+
+release: distcheck
+ @cvs tag rel-`echo $(VERSION) | sed -e 's/\./-/g'` && \
+ read -e -p "SourceForge login: " USER && \
+ read -r -s -p "Password: " PASSWORD && \
+ echo -e "Release focus:\n\
+ 1 Initial FreshMeat announcement\n\
+ 2 Documentation\n\
+ 3 Code cleanup\n\
+ 4 Minor feature enhancements\n\
+ 5 Major feature enhancements\n\
+ 6 Minor bug fixes\n\
+ 7 Major bug fixes\n\
+ 8 Minor security fixes\n\
+ 9 Major security fixes" && \
+ read -e -p "Choice: " FOCUS && \
+ $$VISUAL $(NOTES) && \
+ copher -u $$USER -P $$PASSWORD -p $(PACKAGE) -k $(PACKAGE) -r $(VERSION) -N $(NOTES) $(PACKAGE)-$(VERSION).tar.gz && \
+ fm-submit --no-stdin -p $(PACKAGE) -v $(VERSION) -c "`cat $(NOTES)`" -r $$FOCUS