aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorReuben Thomas <rrt@sc3d.org>2007-12-09 16:09:18 +0000
committerReuben Thomas <rrt@sc3d.org>2007-12-09 16:09:18 +0000
commit600afc7ff1df3aedc69dd34d7a3d8c0a40b10a82 (patch)
tree578f8a3d4a842f89e184fc966ed6cc18d9564f92 /Makefile.am
parent6850f74d8f4c1ac2353ddd460590f1af8edb5572 (diff)
downloadplptools-600afc7ff1df3aedc69dd34d7a3d8c0a40b10a82.tar.gz
plptools-600afc7ff1df3aedc69dd34d7a3d8c0a40b10a82.tar.bz2
plptools-600afc7ff1df3aedc69dd34d7a3d8c0a40b10a82.zip
Remove autogen.sh and hence Makefile.am.in (becomes Makefile.am), and
add a note about use of autoreconf to INSTALL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1d84b9e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+# $Id$
+#
+
+SUBDIRS = intl po lib ncpd plpnfsd plpfuse plpftp plpprint sisinstall doc .
+
+EXTRA_DIST = CHANGES COPYING README TODO HISTORY INSTALL ABOUT-NLS include/*.h* \
+ etc/*magic etc/*.in etc/*.c etc/psidump* etc/udev-usbserial-plptools.rules \
+ conf/m4/plptools/*.m4 conf/[a-l]* conf/missing conf/mkinstalldirs \
+ debian/*
+DISTCLEANFILES = etc/psion etc/psion.SuSE
+
+TMPDEST=
+
+install-data-local:
+ test "$(initdir)" != "none" && \
+ install -m 755 etc/psion $(DESTDIR)$(initdir)/psion || :
+
+dist-hook:
+ $(MAKE) TMPDEST=$(distdir)/ kdoc specfile
+ test -f CVS/Root && cvs2cl -W 1800 -S --no-wrap --prune \
+ --gmt -f $(distdir)/ChangeLog || \
+ cp -f ChangeLog $(distdir)/ChangeLog
+ rm -rf $(distdir)/debian/CVS
+
+kdoc:
+ kdoc -d $(TMPDEST)doc/api -n libplp --strip-h-path $(TMPDEST)lib/*.h
+
+specfile:
+ sed -e "s/\@VERSION\@/$(VERSION)/" < $(TMPDEST)etc/plptools.spec.in \
+ > $(TMPDEST)etc/plptools.spec
+
+ACLOCAL_AMFLAGS = -I m4