aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHenrik Rydberg <rydberg@euromail.se>2008-11-03 00:49:34 +0100
committerHenrik Rydberg <rydberg@euromail.se>2008-11-03 00:49:34 +0100
commit70ba2dbf0f49a4f8d1caa2bbed97c8c2358c6fb6 (patch)
treee1697049bc32fd47b1e639969b4ff752689c92a8 /debian/rules
downloadxorg-input-kobomultitouch-70ba2dbf0f49a4f8d1caa2bbed97c8c2358c6fb6.tar.gz
xorg-input-kobomultitouch-70ba2dbf0f49a4f8d1caa2bbed97c8c2358c6fb6.tar.bz2
xorg-input-kobomultitouch-70ba2dbf0f49a4f8d1caa2bbed97c8c2358c6fb6.zip
Initial version: adding some files
Signed-off-by: Henrik Rydberg <rydberg@euromail.se>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..90568c9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build-arch:
+ dh_testdir
+ $(MAKE)
+
+build-indep:
+
+build: build-arch build-indep
+
+install:
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) DESTDIR=$(CURDIR)/debian/hal-applesmc install
+
+binary-arch: build-arch install
+ dh_testdir
+ dh_testroot
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-indep: build-indep
+
+binary: binary-arch binary-indep
+
+clean:
+ dh_testdir
+ dh_testroot
+ $(MAKE) clean
+ dh_clean
+
+.PHONY: build-arch build-indep build install binary-arch binary-indep binary clean
+