aboutsummaryrefslogtreecommitdiffstats
path: root/bba/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'bba/CMakeLists.txt')
-rw-r--r--bba/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/bba/CMakeLists.txt b/bba/CMakeLists.txt
new file mode 100644
index 00000000..e06d8b1d
--- /dev/null
+++ b/bba/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.3)
+project(bba)
+
+find_package(Boost REQUIRED COMPONENTS
+ program_options
+ filesystem
+ system)
+
+add_executable(bbasm
+ main.cc)
+target_link_libraries(bbasm LINK_PRIVATE
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY})
+export(TARGETS bbasm FILE ${CMAKE_BINARY_DIR}/bba-export.cmake)