aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/sanitizers-cmake/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/sanitizers-cmake/tests/CMakeLists.txt')
-rw-r--r--3rdparty/sanitizers-cmake/tests/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/3rdparty/sanitizers-cmake/tests/CMakeLists.txt b/3rdparty/sanitizers-cmake/tests/CMakeLists.txt
new file mode 100644
index 00000000..6ffb38fb
--- /dev/null
+++ b/3rdparty/sanitizers-cmake/tests/CMakeLists.txt
@@ -0,0 +1,52 @@
+# This file is part of CMake-sanitizers.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in all
+# copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+#
+#
+# Copyright (c)
+# 2013-2015 Matt Arsenault
+# 2015 RWTH Aachen University, Federal Republic of Germany
+#
+
+# Function to add testcases.
+function(add_testcase TESTNAME SOURCEFILES)
+ # remove ${TESTNAME} from ${ARGV} to use ${ARGV} as ${SOURCEFILES}
+ list(REMOVE_AT ARGV 0)
+
+ # add a new executable
+ add_executable(${TESTNAME} ${ARGV})
+ add_sanitizers(${TESTNAME})
+
+ # add a testcase for executable
+ add_test(${TESTNAME} ${TESTNAME})
+endfunction(add_testcase)
+
+
+
+#
+# search for sanitizers
+#
+find_package(Sanitizers)
+
+
+
+#
+# add testcases
+#
+add_testcase("asan_test_cpp" asan_test.cpp)