aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-06-02 12:09:40 +0100
committergatecat <gatecat@ds0.me>2021-06-02 15:05:20 +0100
commitdcbb322447a7fb59cabe197ec1dd2307acfa3681 (patch)
treeada2c6a5d48e766fa523e633aaa28179baea3273 /CMakeLists.txt
parent897e2c2fdc43bcf097aa8805c424c4443bcefad5 (diff)
downloadnextpnr-dcbb322447a7fb59cabe197ec1dd2307acfa3681.tar.gz
nextpnr-dcbb322447a7fb59cabe197ec1dd2307acfa3681.tar.bz2
nextpnr-dcbb322447a7fb59cabe197ec1dd2307acfa3681.zip
Remove redundant code after hashlib move
Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 233d5797..42d55a97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,6 @@ option(EXTERNAL_CHIPDB "Create build with pre-built chipdb binaries" OFF)
option(WERROR "pass -Werror to compiler (used for CI)" OFF)
option(PROFILER "Link against libprofiler" OFF)
option(USE_IPO "Compile nextpnr with IPO" ON)
-option(USE_ABSEIL "Compile nextpnr with Abseil for faster hash map" OFF)
if (USE_IPO)
if (ipo_supported)
@@ -199,10 +198,6 @@ if (NOT DEFINED CURRENT_GIT_VERSION)
)
endif()
-if (USE_ABSEIL)
- add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
-endif()
-
if (BUILD_TESTS)
add_subdirectory(3rdparty/googletest/googletest ${CMAKE_CURRENT_BINARY_DIR}/generated/3rdparty/googletest EXCLUDE_FROM_ALL)
enable_testing()
@@ -252,13 +247,7 @@ else()
endif()
set(EXTRA_LIB_DEPS)
-if (USE_ABSEIL)
- if (NOT USE_THREADS)
- message(FATAL_ERROR "Abseil without threads is not supported")
- endif()
- list(APPEND EXTRA_LIB_DEPS absl::flat_hash_map)
- list(APPEND EXTRA_LIB_DEPS absl::flat_hash_set)
-endif()
+
if(PROFILER)
list(APPEND EXTRA_LIB_DEPS profiler)
endif()
@@ -336,9 +325,6 @@ foreach (family ${ARCH})
target_compile_definitions(${target} PRIVATE QT_NO_KEYWORDS)
target_link_libraries(${target} LINK_PUBLIC gui_${family} ${GUI_LIBRARY_FILES_${ufamily}})
endif()
- if (USE_ABSEIL)
- target_compile_definitions(${target} PRIVATE USE_ABSEIL)
- endif()
if (BUILD_PYTHON)
target_link_libraries(${target} LINK_PUBLIC ${PYTHON_LIBRARIES})
if (STATIC_BUILD)