aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2020-06-24 17:57:24 +0000
committerwhitequark <whitequark@whitequark.org>2020-06-25 14:03:37 +0000
commitbf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca (patch)
treec804de40d0daf000e6c0d48f12c8ae76b7fe423a /CMakeLists.txt
parent1dc1164dce88fade762956c1067aeb97fa3c0f9a (diff)
downloadnextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.tar.gz
nextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.tar.bz2
nextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.zip
CMake: require at least version 3.5 (Ubuntu 16.04).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d5b1dc9..07c5fb7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,4 @@
-# TODO: sensible minimum CMake version
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.5)
project(nextpnr CXX)
option(BUILD_GUI "Build GUI" ON)