aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2021-03-12 03:00:58 +0000
committerwhitequark <whitequark@whitequark.org>2021-03-12 03:00:58 +0000
commitbdf13ddcfbbdc2bd08270fbb72fec448f28e69c9 (patch)
tree605f47b65331ffda271d5b2353f317fff99f7f61 /CMakeLists.txt
parentcc367d7e678f42f44ab029f2f3c372e4a09ed19d (diff)
downloadnextpnr-bdf13ddcfbbdc2bd08270fbb72fec448f28e69c9.tar.gz
nextpnr-bdf13ddcfbbdc2bd08270fbb72fec448f28e69c9.tar.bz2
nextpnr-bdf13ddcfbbdc2bd08270fbb72fec448f28e69c9.zip
CMake: Don't include Abseil if it is not used.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3df6a58..6ebc2e75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,7 +171,9 @@ if (NOT DEFINED CURRENT_GIT_VERSION)
)
endif()
-add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+if (NOT WASI)
+ add_subdirectory(3rdparty/abseil-cpp EXCLUDE_FROM_ALL)
+endif()
if (BUILD_TESTS)
add_subdirectory(3rdparty/googletest/googletest ${CMAKE_CURRENT_BINARY_DIR}/generated/3rdparty/googletest EXCLUDE_FROM_ALL)