aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Shah <davey1576@gmail.com>2018-06-13 13:09:37 +0200
committerDavid Shah <davey1576@gmail.com>2018-06-13 13:09:37 +0200
commitb88593ef7d8add9ad67ecf9817a16fa987684728 (patch)
tree2a1b3a906acd769c9881ed4541831dd097fe73c9 /CMakeLists.txt
parent4694c6aae7656b22fa94db9a252ed046faf40244 (diff)
downloadnextpnr-b88593ef7d8add9ad67ecf9817a16fa987684728.tar.gz
nextpnr-b88593ef7d8add9ad67ecf9817a16fa987684728.tar.bz2
nextpnr-b88593ef7d8add9ad67ecf9817a16fa987684728.zip
cmake: Fixing the installer
Signed-off-by: David Shah <davey1576@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74a94ae4..b9c0ff6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ execute_process(
OUTPUT_STRIP_TRAILING_WHITESPACE
)
-add_subdirectory(3rdparty/googletest/googletest)
+add_subdirectory(3rdparty/googletest/googletest EXCLUDE_FROM_ALL)
enable_testing()
add_definitions("-DGIT_COMMIT_HASH=${GIT_COMMIT_HASH}")
@@ -89,6 +89,7 @@ foreach (family ${FAMILIES})
aux_source_directory(tests/${family}/ ${ufamily}_TEST_FILES)
# Add the CLI binary target
add_executable(nextpnr-${family} ${COMMON_FILES} ${${ufamily}_FILES} ${GUI_SOURCE_FILES})
+ install(TARGETS nextpnr-${family} RUNTIME DESTINATION bin)
target_compile_definitions(nextpnr-${family} PRIVATE MAIN_EXECUTABLE)
# Add the importable Python module target